Is Rclone downloading the entire data for Plex Scan?

What is the problem you are having with rclone?

I am using Gdrive with Plex using rclone mount. Off late, scans take forever. It appears to me that entire content is being downloaded for the scans. My understanding is that Plex scan online requires a media probe so that only a small segment of the file should be downloaded.

What is your rclone version (output from rclone version)

$ rclone version
rclone v1.54.0-beta.4793.2b7994e73
- os/arch: linux/amd64
- go version: go1.15.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

$ cat /etc/os-release
VERSION="20.04.1 LTS (Focal Fossa)"
PRETTY_NAME="Ubuntu 20.04.1 LTS"

Which cloud storage system are you using? (eg Google Drive)

Google Drive.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount td_media_crypt: ~/td_media --allow-other --buffer-size 256M --use-mmap --dir-cache-time 100h --timeout 1h --poll-interval 15s --vfs-cache-mode full --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit 1G --buffer-size 512M --tpslimit-burst 10 --tpslimit 10 --vfs-cache-max-size 200G --vfs-cache-max-age 336h --log-level DEBUG --log-file /mnt/data/rclone/logs/rclone_td_media_crypt.log --cache-dir /mnt/data/rclone/cache

The rclone config contents with secrets removed.

type = drive
client_id =
client_secret = blahblahblah
scope = drive
service_account_file = /home/blah/rcltemp-123e.json
service_account_file_path = /home/blah/
team_drive = blahblahblah

type = crypt
remote = td_media:
filename_encryption = standard
directory_name_encryption = true
password = blahblah
password2 = blahblahblahblahblahblahblahblah

I have tried even with a non-SA remote.

A log from the command with the -vv flag

Here are two different parts of the logs that suggest that it is downloading a lot (please let me know if you are looking for something additional).

No, Plex only uses a few parts of the file, but it does depend on what Plex settings you have.

Any specific settings that you are thinking of?

I disabled everything in the library (intro detection, preview thumbnails).

That helps as well.

Also, I'd remove:

--buffer-size 256M --use-mmap --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit 1G --buffer-size 512M --tpslimit-burst 10 --tpslimit 10 --vfs-cache-max-size 200G

and let it use the defaults.

Why exclude --vfs-cache-max-size 200G? What is the default value of the cache? I just thought increasing the cache value will improve rclone performance.

Typo. Keep that and set to your requirements.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.