InvalidAuthenticationToken: Unable to initalize RPS

What is the problem you are having with rclone?

getting an error when running a OneDrive Personal sync or cryptcheck or basically anything. error says "InvalidAuthenticationToken: Unable to initalize RPS" on random instances during the process, not for every file. rclone is doing this on three different systems. i've tried to do a refresh token, i've closed and reopened rclone, still coming back to the same thing.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows Server 2019

Which cloud storage system are you using? (eg Google Drive)

Microsoft OneDrive Personal

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone cryptcheck --verbose -vv "C:\Users\Administrator\Documents\Shares\Corissa" "JOfficeHomeCrypt:Corissa"

The rclone config contents with secrets removed.

type = onedrive
token = {"access_token":"blahblahbahahaha","token_type":"Bearer","refresh_token":"a;lsdfja;ldjf;ladfjs","expiry":"2021-04-17T09:37:52.5549527-05:00"}
drive_id = fsafd675sdaf97619
drive_type = personal

type = crypt
remote = JOfficeHome:SL Server
filename_encryption = standard
directory_name_encryption = false
password =

A log from the command with the -vv flag

C:\Users\Administrator>cd C:\rclone 1.54.1

C:\rclone 1.54.1>rclone cryptcheck --verbose -vv "C:\Users\Administrator\Documents\Shares\Corissa" "JOfficeHomeCrypt:Corissa"
2021/04/17 08:46:43 DEBUG : rclone: Version "v1.54.1" starting with parameters ["rclone" "cryptcheck" "--verbose" "-vv" "C:\\Users\\Administrator\\Documents\\Shares\\Corissa" "JOfficeHomeCrypt:Corissa"]
2021/04/17 08:46:43 DEBUG : Creating backend with remote "C:\\Users\\Administrator\\Documents\\Shares\\Corissa"
2021/04/17 08:46:43 DEBUG : Using config file from "C:\\Users\\Administrator\\.config\\rclone\\rclone.conf"
2021/04/17 08:46:43 DEBUG : fs cache: renaming cache item "C:\\Users\\Administrator\\Documents\\Shares\\Corissa" to be canonical "//?/C:/Users/Administrator/Documents/Shares/Corissa"
2021/04/17 08:46:43 DEBUG : Creating backend with remote "JOfficeHomeCrypt:Corissa"
2021/04/17 08:46:44 DEBUG : Creating backend with remote "JOfficeHome:SL Server/rh37tldbvrpmnan0br2ra6sng4"
2021/04/17 08:46:44 DEBUG : Creating backend with remote "JOfficeHome:SL Server/Corissa"
2021/04/17 08:46:45 INFO  : Using SHA-1 for hash comparisons
2021/04/17 08:46:45 DEBUG : Encrypted drive 'JOfficeHomeCrypt:Corissa': Waiting for checks to finish
2021/04/17 08:46:45 ERROR : .DS_Store: error computing hash: failed to open object to read nonce: InvalidAuthenticationToken: Unable to initialize RPS
2021/04/17 08:46:45 DEBUG : Floor Production Shelf Layout.docx: OK
2021/04/17 08:46:45 DEBUG : 2021-year-calendar-template-us-holidays-02.doc: OK
2021/04/17 08:46:45 DEBUG : Description of Jesus from our Psalm 45 Lehr.docx: OK
2021/04/17 08:46:45 DEBUG : 55 Old Testament Prophecies about Jesus.docx: OK
2021/04/17 08:46:46 DEBUG : Forgiveness for Us.docx: OK
2021/04/17 08:46:46 DEBUG : HOMEMADE OVEN CLEANER SPRAY.docx: OK
2021/04/17 08:46:46 DEBUG : HOMEMADE LAUNDRY DETERGENT.docx: OK
2021/04/17 08:46:46 DEBUG : Mother's Day songs.docx: OK
2021/04/17 08:46:46 DEBUG : Jesus Heilige Woche.docx: OK
2021/04/17 08:46:46 DEBUG : Poems written by students 2.pdf: OK
2021/04/17 08:46:46 DEBUG : Poems written by students.pdf: OK
2021/04/17 08:46:46 DEBUG : Preface 30 translation L.docx: OK
2021/04/17 08:46:46 DEBUG : Screenshot 2021-02-16 131011.png: OK

there are a bunch of post in the forum about that. pretty sure that includes a possible solution or workaround.

there could be a new issue with onedrive and crypt as detailed in this post

yeah it seems there's a new issue with OneDrive Crypt remotes.. unlike the other user i'm not getting emails about ransomware issues. yet.

are you using onedrive, personal or business?

i have a small onedrive business crypt for a long time, never got any emails.

as a test, yesterday, i create a crypt on onedrive personal and waiting for that email.

my apologies. it's OneDrive Personal, as the original post now shows.

have not been getting any errors on OneDrive Business thus far.

waiting for the email as well.

Same problem here. Onedrive backup (personal drive) worked fine until yesterday, but starting tonight I started receiving these errors:

error reading source directory: couldn't list files: InvalidAuthenticationToken: Unable to initialize RPS

This has happened simultaneously on 3 on 3 family accounts.
I am not using any encryption on Onedrive.

This is surely a onedrive regression...

Or it might be targeted specifically at rclone - can someone who is having the problem try adjusting --user-agent and see if that makes a difference?


Having the same issue (rclone 1.55.0, OneDrive Personnal). I thought it was related to this :

It looks like it's not the case.

I just tried to adjust --user-agent by adding it to my usual sync command :

sudo rclone sync /var/lib/docker/volumes/nextcloud/_data/data/JS/files/Pro Cabinet: -vv --delete-excluded --log-file=/home/pi/scripts/cabinet-cron.log --create-empty-src-dirs --user-agent Cabinet

I'm still getting random errors :

2021/04/18 16:04:15 DEBUG : Dossiers/0 - Archive/XXX c MP/4 - Pièces/Copie intégrale de la procédure.pdf: Unchanged skipping
2021/04/18 16:04:15 ERROR : Dossiers/0 - Archive/XXX c MP/6 - Copies pénales/D: error reading destination directory: couldn't list files: InvalidAuthenticationToken: Unable to initialize RPS
2021/04/18 16:04:16 DEBUG : Dossiers/0 - Archive/XXX c MP/4 - Pièces/Bulletin solde décembre 2018.pdf: Size and modification time the same (differ by 0s, within tolerance 1s)

As sweh noticed in another topic, it might be a wider issue :


  • did the issue just start to happen?
  • did you recently update rclone?
  • are you using a rclone crypt remote?
  • The issue started ~ 3 days ago. It still has not solved by itslef as I saw on some older topics on this forum.

  • I recently updated to rclone 1.55 (was using the previous version) but I can't tell you exactly when.

  • I'm using rclone crypt remote (had an issue with Onedrive ransomware protection but it does not look like it's linked to this issue).

have you tried

does onedrive personal have service accounts, which do not use access tokens?

This command is used to renew token ?
If yes, then I renewed my token yesterday just in case, it had no effect on the issue.

Did rclone config reconnect Onedrive: without renewing token, still getting random ERROR.

Hello everyone, I'm having the same issue with OneDrive Personal in the sync mode from OneDrive to my machine.
OS: Debian 10 (Buster)
rclone version 1.55.0

Issue noted on April 16. Last time issue confirmed April 19th.

I'm syncing about 80.000 files and getting about 20-60 "Unable to initalize RPS" errors on random files on each march. Rclone still syncs flies if any difference found, but as errors appear it repeats the cycle 3 times and then reports about unsuccessful sync.


  • refresh the key, did not help,
  • generate and use my own client ID and the key, did not help,
  • slow down the operation speed with --tpslimit 0.2, it decreased the speed to about 100 file checks per minute but it did not help, RPS errors still appear randomly in similar proportion.

Temporary workaround that does not really fix anything but makes life a bit easier:

  • set "--ignore-errors" to allow rclone to delete files in destination when syncing because it won't otherwise if a single error appear
  • set "--retries 1" to limit sync to only one retry cycle to avoid syncing default 3 times with the same result each time

Reading this forum I see this issue is happening time to time. Hope it is not an rclone bug and that MS fixes it soon.

How many files are changing, how many directories are they in, and what are their sizes?

In my case my tree is around 1800 files in size and I typically only update 40-80 files per day, each approx 5Gb each, and delete a similar number (rotating backups). So the number of API calls made by rclone to the Graph API won't be that many.

Do you upload 80,000 files each time, or just checking that many?

In my case ~80K is the total number of files. Nothing too special: personal pictures, music etc, with overall size of about 600Gb. Each folder can hold up to ~100s of files. Each day a small number of items (less than 100) may update or it can be no change.

I'm running sync daily to sync my local drive with the cloud. I suppose each run checks all the files (or at least hashes), that means that each file/folder should be called via API to OneDrive. If not limiting the "--tpslimit" the whole sync operation may take 15-20 minutes considering that there is nothing to transfer (or almost nothing).


if you sync on a daily basis, might want to add --max-age=25h
if a local file has been modified within the last 25 hours, then rclone will check the corresponding fie in gdrive, if it exists, and decided what to do.
if the local file does not exist, then rclone will copy it.
if a local file modtime is older than 25 hours, then do nothing.
so instead of 80k of checks, rclone would perform just ~100 checks.

this is hit and miss. for instance:

  • if someone moves a file to a different folder without modifying it, rclone will skip over it and the move will not be reflected in the cloud remote.
  • if someone adds a file to the directory from a different directory without modifying it, this file will also be skipped.
  • renaming a file will not constitute as "modified", so rclone will also skip over old files that are just renamed.

the --max-age flag has it's uses for filtering, certainly, but i haven't found it particularly fitting for making large directory syncs more efficient.

those are good points

I have 4 syncs running daily :

  • The ones with 635 and 255 files have no problem at all.
  • The ones with 15320 (~20gigs) and 20545 (~450mo) show the random error and do not properly sync.

I switched one of my remote to Scaleway S3 while waiting for this issue to end...

I have the same problem, even running the ls remote: command.