Invalid memory address or nil pointer dereference error when copy to Google photos

What is the problem you are having with rclone?

When I try to do an automated upload to Google Photos storage, I get a memory error and the upload fails.

Sometimes this happens, sometimes it doesn't (i.e., sometimes it uploads fine), and when it does start happening, it lasts for hours (as long as 20 hours).

My guess is that it's probably happening when I reach GPhotos' daily upload limit, but when I do, it used to print an error related to Upload Quota, so I could easily see why, but now it doesn't print that error and says it's a memory error.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.0

  • os/version: unknown
  • os/kernel: 4.4.302+ (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Photos

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone move "/volume1/Backup/Google Photos Backup" "gsuitephoto:upload" --exclude="@eaDir/**" --exclude=".DS_Store" --transfers 15 -vv

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = google photos
client_id = XXX
client_secret = XXX
token = XXX

A log from the command that you were trying to run with the -vv flag

I'd like to provide additional information. I installed rclone on a Synology NAS via SSH.

To help with finding the root cause of this issue would you mind to run your command with addition of --dump headers flag when the issue is happening?

It is possible that Google has changed something - maybe error code etc. and rclone does not handle it nicely - it should.

Hello kapitainsky.

Thank you for answer. I tried with flag --dump headers and result was like below.

Can you know something else with this log?

Thanks for doing that.

I can see what the problem is.

Can you try this please?

v1.66.0-beta.7581.595bf074b.fix-gphotos-nil-pointer on branch fix-gphotos-nil-pointer (uploaded in 15-30 mins)

Hello ncw.

Thanks for your reply.

Unfortunately, refreshing the token we use when configuring the Google Photos config once solved the problem, so it's not happening again now, but I'll test what you said if the same issue recurs.

Thanks for your help.

I'm pretty sure that fix is correct so I've merged this to master now which means it will be in the latest beta in 15-30 minutes and released in v1.65.1

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.