Interrupt during mount

What is the problem you are having with rclone?

While mounting it timeouts due to massive cache delete actions.

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: ubuntu 20.04 (64 bit)
  • os/kernel: 5.4.0-144-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Dropbox over a crypt mount

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount crypt: /mnt/box --log-file /mnt/plex-cache/rclone/logs/rclone_box.log --cache-dir /mnt/plex-cache/rclone --read-only --dropbox-batch-mode sync --transfers 64 --dropbox-chunk-size 128M --dropbox-batch-size 64 -v --drive-chunk-size 128M --vfs-cache-mode full --vfs-read-ahead 256M --vfs-cache-max-size 10000G --vfs-cache-max-age 100000h --dir-cache-time 1000000h --vfs-read-chunk-size 256M --allow-other --daemon

The rclone config contents with secrets removed.

type = dropbox
token = 

type = crypt
remote = box:
filename_encryption = standard
password = 
password2 = 

A log from the command with the -vv flag

Is that really needed? I have -v and I think it's a basic behavior of the mount to do that, but I just search for a way to increase the timeout so it can finish this tasks

PATH/FILE: vfs cache: removed cache file as Removing old cache file not in use
2023/03/24 08:50:27 Fatal error: mount not ready
2023/03/24 08:50:27 INFO  : Signal received: interrupt
2023/03/24 08:50:27 INFO  : Dropbox root '': Committing uploads - please wait...
2023/03/24 08:50:27 INFO  : Exiting...

So my question is: How can I increase the timeout? As you see it gets and interrupt and can't finish it's cleanup task while mounting, thus I have to manually mount it several time once everything is done, if so, it's mounted successfully.

Check out:

Do you mean the --daemon-wait-flag?

1 Like

Yes that is it.

Seems to work, even tho I got the error error: failed to mount FUSE fs: fusermount: exec: "fusermount3": executable file not found in $PATH, but after installing fuse3 it worked perfectly fine, thank you! :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.