Impossible to mount google drive on mac OS Monterey

What is the problem you are having with rclone?

Imposible to mount Gdrive in ~/gdrive

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.1

  • os/version: darwin 12.7.2 (64 bit)

  • os/kernel: 21.6.0 (x86_64)

  • os/type: darwin

  • os/arch: amd64

  • go/version: go1.21.5

  • go/linking: dynamic

  • go/tags: cmount

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount Gdrive: ~/gdrive --allow-other -vv

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = drive
client_id = XXX
client_secret = XXX
scope = drive
token = XXX
team_drive = XXX
root_folder_id = 

A log from the command that you were trying to run with the -vv flag

rclone mount --allow-other  Gdrive: ~/gdrive/
kext load failed: -603947007
mount_osxfuse: the file system is not available (255)
2024/01/21 22:39:08 ERROR : Google drive root '': Mount failed
2024/01/21 22:39:08 Fatal error: failed to mount FUSE fs: mount stopped before calling Init: mount failed

It is not rcone issue but some macFUSE problem. Rclone requires this kext (kernel extension) to be loaded in order for mount to work.

You can try:

  1. reinstall the latest version from Make sure that you allow this extension to be loaded in Security settings of System settings

  2. uninstall macFUSE completely and install FUSE-T from

I appreciate the help,
Following the steps you proposed, I do get a different message, and it is true that it seems like a FUSE T problem, but I can't get it to work. Now I get a different error than the previous one, but I still can't get it.

Nuevo-MacBook-Pro-de-Alberto:~ Alberto$ rclone mount Gdrive: ~/gdrive --allow-other -vv

2024/01/22 10:31:19 DEBUG : rclone: Version "v1.65.1" starting with parameters ["rclone" "mount" "Gdrive:" "/Users/Alberto/gdrive" "--allow-other" "-vv"]

2024/01/22 10:31:19 DEBUG : Creating backend with remote "Gdrive:"

2024/01/22 10:31:19 DEBUG : Using config file from "/Users/Alberto/.config/rclone/rclone.conf"

2024/01/22 10:31:20 DEBUG : Mounting on "/Users/Alberto/gdrive" ("Gdrive")

2024/01/22 10:31:20 DEBUG : Adding "-o modules=iconv,from_code=UTF-8,to_code=UTF-8-MAC" for macOS

2024/01/22 10:31:20 DEBUG : Google drive root '': Mounting with options: ["-o" "attr_timeout=1" "-o" "fsname=Gdrive:" "-o" "subtype=rclone" "-o" "max_readahead=131072" "-o" "atomic_o_trunc" "-o" "daemon_timeout=600" "-o" "allow_other" "-o" "volname=Gdrive" "-o" "noappledouble" "-o" "modules=iconv,from_code=UTF-8,to_code=UTF-8-MAC"]

2024/01/22 10:31:20 DEBUG : Google drive root '': Init:

2024/01/22 10:31:20 DEBUG : Google drive root '': >Init:

fuse: mount failed with errro: -1

fuse: reading error: Bad file descriptor

2024/01/22 10:31:20 DEBUG : Google drive root '': Destroy:

2024/01/22 10:31:20 DEBUG : Google drive root '': >Destroy:

2024/01/22 10:31:20 ERROR : Google drive root '': Mount failed

2024/01/22 10:31:20 DEBUG : Not calling host.Unmount as mount already Destroyed

2024/01/22 10:31:20 DEBUG : Unmounted successfully

2024/01/22 10:31:20 ERROR : /Users/Alberto/gdrive: Unmounted rclone mount

2024/01/22 10:31:20 Fatal error: failed to umount FUSE fs: mount failed

Uninstall macFUSE completely before trying to use FUSE-T.

You can find plenty of info on Google how to do it, e.g.:

Yes, I had already tried it, but I tried it again in case I had left something out along the way.
I have read the post you sent me and it seems that I do uninstall macFUSE completely, it disappears from my preferences panel, and I have reinstalled TFUSE, but I get the same error.
Thank you very much for the help, but I think I'll have to give up.

For sure it is some mess with previous kext installations...

There is an alternative available in the latest rclone:

rclone nfsmount Gdrive: ~/gdrive --allow-other

It should work pretty well if you only read data from your mount. Writing is still a bit buggy. Give it a try.

Still not lucky:

rclone nfsmount Gdrive: ~/gdrive --allow-other

2024/01/22 11:42:37 WARNING: context.Background: NFS writes don't work without a cache, the filesystem will be served read-only

2024/01/22 11:42:37 NOTICE: NFS Server running at

2024/01/22 11:42:37 Fatal error: failed to mount FUSE fs: mount_nfs: can't mount from localhost onto /Users/Alberto/gdrive: Operation not permitted

mount: /Users/Alberto/gdrive failed with 1: failed to mount NFS volume: exit status 1

I have just tried rclone nfsmount on macOS Monterey 12.7.2 without any FUSE installed - works like a charm.

Then I installed FUSE-T and tried rclone mount - again no issues.

So unfortunately IMO it looks like it is not rclone issue but something specific with FUSE and your computer setup. Maybe some other software interfering, some settings you changed etc.

Maybe permissions of /Users/Alberto/gdrive directory? Maybe some "antivirus" solution your are using?

It worked!!!
You gave me a clue.
Before asking here, i was reading posts, and i read that my ~/gdrive folder has to be owned by root. So i did it.
Captura de Pantalla 2024-01-22 a las 13.03.10

I tried to change the owner back to Alberto user, and it worked!

Thanks so much for the help

1 Like

Glad it worked:) I have to say FUSE/rclone error messages are not help at all in identifying the root cause of the issue.

One more thing now that i know that you have a MacOS.

Is there any rclone option, or way to close the terminal after mounting the drive?
I can close it manually when rclone leaves the prompt hanging, but i can't get it to close automatically when using alias to launch it.

Thanks so much in advance

Terminal is fine for experimenting and testing but for "production" I would use launchd (it is similar to linux systemd). Here some basic explanations:

You can also try to use macOS automation tools like shortcuts. They support shell scripts as well.

Just google for some examples.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.