Impossible to connect to ftp folder after rclone mount

What is the problem you are having with rclone?

I use ubuntu server as ftp server. The fpt with filezilla works fine, rclone copy on the ftp folder works correctly as well.
Problem starts when I do rclone mount on the ftp folder, because then I cannot connect to that folder with filezilla anymore (error 500 OOPS: cannot change directory:/home/ftpuser/ftp)... nor I can see the rclone pid to kill it or unmount it. Any ideas? Thanks.

The /home/ftpuser/ftp is own by the ftpuser and I run the rclone commans as ftpuser as well.

What is your rclone version (output from rclone version)

rclone v1.52.2

  • os/arch: linux/arm64
  • go version: go1.14.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Linux ubuntu 5.4.0-1015-raspi #15-Ubuntu SMP Fri Jul 10 05:34:24 UTC 2020 aarch64 aarch64 aarch64 GNU/Linux

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone --vfs-cache-mode writes mount --verbose --daemon  --allow-non-empty "onedrive":raspberry_ftp ~/ftp

The rclone config contents with secrets removed.

cat .config/rclone/rclone.conf
type = onedrive
token = ...

A log from the command with the -vv flag

Paste  log here

Does the FTP server only allow a limited number of connections?

Unmount the mount with

fusermount -u /path/to/mountpoint

Add -z if it complains about it being in use

It doesn't have a limited number of connections. The fusermount unmount rclone, but I need the mount command to monitor the folder and upload any new files on onedrive.

Are you trying to export an rclone mount with samba?

If so try the --allow-other flag

No, I'm using a raspberry with ubuntu server, where I mounted rclone to upload to onedrive the video a ftp camera send to that specific folder...
But, when I run rclone mount, the ftp doesn't allow any other connection (as I said).
Probably rclone mount change something in the folder...

Have you looked at the FTP server log? in /var/log most likely. That might tell you what is going on.

I tried, but it didn't help... This is the only information you can see in the log (a list of cconnect + the user)

Tue Aug 18 17:27:00 2020 [pid 12404] CONNECT: Client "::ffff:"
Tue Aug 18 17:27:00 2020 [pid 12403] [ftpuser] OK LOGIN: Client "::ffff:"

If you stop the mount, see how many times you can log in a the same time with an FTP client?

Rclone will log in multiple times. You might want to adjust the concurrency (see the FTP backend docs)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.