Ignoring local NTFS "system" directories

I have a whole drive that I am sync-ing with OneDrive and now ACD.

The desktop app for ACD blows goats. Hence rclone.

Problem is I cannot figure out anyway of ignoring the system directories in the root of the drive, namely $RECYCLE.BIN and System Volume Information.

2017/03/01 16:10:50 amazon drive root ‘’: Building file list
2017/03/01 16:10:50 Local file system at \?\F:: Building file list
2017/03/01 16:10:50 Local file system at \?\F:: Error building file list: error listing: Local file system at \?\F:: failed to open directory “\\?\F:\$RECYCLE.BIN\S-[XXX]”: open \?\F:$RECYCLE.BIN\S-[XXX]: Access is denied.
(Note many quad \ strings above have been replaces by the forum software…)

I have tried simple patterns like “$*” or “/$RECYCLE.BIN” and even cut/paste from the above into an exclude file with or without substituting the single/double backslashes for forward ones.

I really don’t want to move all my local references around to directories, so putting everything in a single top-level directory (which is the obvious workaround) is one thing I want to avoid at this point.

I also can’t find a “skip” option to ignore directories that cannot be opened. Which would help.


I’ve sort of worked around this using --include-from and listing the directories I have, but this means manual intervention in the future; so

rclone [ check --size-only ] --include-from rclone-files.txt amazon: F:\

… etc

He he :slight_smile:

Recycle bin is a directory, so you’ll want “$/" or "/$RECYCLE.BIN/". You might need "$” or “/$RECYCLE.BIN” as well.

There is an issue about this: https://github.com/ncw/rclone/issues/1101

I've created a file ~/rclone.txt with:

System Volume Information/

and I'm doing:
rclone sync /SOURCE/ /TARGET/ -P --exclude-from ~/rclone.txt