IB-NAS4220-B with OpenWRT

Hello, I have a NAS IB-NAS4220-B with OpenWRT Barrier Breaker installed on it.

The output of cat /proc/cpuinfo is:

processor       : 0
model name      : FA526 rev 1 (v4l)
BogoMIPS        : 229.78
Features        : swp half
CPU implementer : 0x66
CPU architecture: 4
CPU variant     : 0x0
CPU part        : 0x526
CPU revision    : 1
Hardware        : Raidsonic NAS IB-4220-B
Revision        : 0000
Serial          : 0000000000000000

I tried to install rclone for ARM, but I get these errors once I try to run rclone config

  • with rclone-v1.42-linux-arm.zip -> Illegal instruction
  • with rclone-v1.42-linux-arm64.zip -> line 1: syntax error: unexpected ")"

What can I do?

I suspect your ARM processor doesn’t have floating point support.

http://wiki.nas-portal.org/index.php/Prozessor_und_Chipsatz states that it is an ARMv4 instruction set

Which isn’t supported by the go runtime (this needs ARMv5 at least, ARMv7 is the current version).

The v4l here also indicates that it is ARMv4 architecture (I think).

So I think you are probably out of luck for this particular NAS.

How old is it?

OK, I supposed it was a problem related to the age of the device… It should be manufactured in late 2008.
Anything else that I can try to sync my googledrive?

Rclone will compile with gccgo - it is possible that you could cross compile an rclone for ARMv4 which would work using that. I haven’t tried that though.

Could you assist me during the process? I don’t have experience doing that.
Thank you.

I note there is a gccgo-arm-linux-gnueabi in the latest ubuntu. There doesn’t appear to be a build wrapper like the go tool so building would require quite a bit of work… I think it probably isn’t worth it :frowning: