I try to play a video on vlc, but when I jump to the timeline it takes a long time to load or freezes loading

What is the problem you are having with rclone?

Hi, I am trying to play a video on vlc, the video starts playing fast, but when I try to jump to the timeline it takes a long time to load or stops loading

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: raspbian 11.7
  • os/kernel: 6.1.21-v7+ (armv7l)
  • os/type: linux
  • os/arch: arm (ARMv7 compatible)
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

streamtape.com with their FTP

The command you were trying to run (eg rclone copy /tmp remote:tmp)

> rclone mount streamtape: /AAA --vfs-cache-mode full --vfs-cache-max-size 100G --vfs-fast-fingerprint --tpslimit 10 --tpslimit-burst 0 --allow-non-empty --allow-other -vv

I entered "--allow-non-empty" so that I wouldn't restart rclone every time I tried to run tests

The rclone config contents with secrets removed.

type = ftp
host = ftp.streamtape.com
pass = XXXXX
tls = false
user = XXXX
explicit_tls = false

-> Clarification to be clearer

Although I am using vlc, I would like to use it for my "Jellyfin" server, only it makes the testing part really tedious (Ex. upload the file, synchronize the folder, synchronize the data, search for the file, play it), so I am using vlc, just to do the testing in a practical and fast way

A log from the command with the -vv flag


The log was too long and so I could not publish the post, I put it in a pastebin

FTP is not known to be very robust protocol - so I would not expect miracles.

Personally I would try to add:

--ftp-concurrency int Maximum number of FTP simultaneous connections (default 0 for unlimited)
--vfs-read-chunk-size SizeSuffix        Read the source objects in chunks (default 128M)
--vfs-read-chunk-size-limit SizeSuffix  Max chunk doubling size (default off)


--ftp-concurrency 3
--vfs-read-chunk-size 64M
--vfs-read-chunk-size-limit 0

I tried this command, adding the flags you recommended:

rclone mount streamtape: /AAA --vfs-cache-mode full --vfs-cache-max-size 100G --vfs-fast-fingerprint --tpslimit 10 --tpslimit-burst 0 --ftp-concurrency 3 --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 0 --allow-non-empty --allow-other -vv

but nothing has changed

(Assumption) I think rclone is trying to download the whole file, and failing to do so it stops, I wonder if there is a way to start the download from the required part not necessarily starting from the beginning

One thing I have noticed is that playing the video normally, so watching it from the beginning without sending it forward, plays smoothly

rclone tries to download files in chunks but it depends if your ftp server supports it - I have know nothing about streamtape

there is a comand to do to understand if an ftp load in chunks?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.