I am not able to do anything with my Google Drive Remote

What is the problem you are having with rclone?

I am not able to do anything with my Google Drive Remote which did work fine yesterday.

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2
- os/version: debian bookworm/sid (64 bit)
- os/kernel: 6.2.6-76060206-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.20.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

# My most wanted command is
rclone mount --daemon Drive: /path/to/mount
# But even for listing directories gives same error
rclone lsd Drive:

The rclone config contents with secrets removed.

type = drive
scope = drive
token = XXXX
team_drive = 

A log from the command with the -vv flag

2023/05/21 12:52:25 DEBUG : rclone: Version "v1.62.2" starting with parameters ["rclone" "lsd" "Drive:" "-vv"]
2023/05/21 12:52:25 DEBUG : Creating backend with remote "Drive:"
2023/05/21 12:52:25 DEBUG : Using config file from "/home/zakmin/.config/rclone/rclone.conf"
2023/05/21 12:52:26 Failed to create file system for "Drive:": couldn't find root directory ID: googleapi: Error 401: Request had invalid authentication credentials. Expected OAuth 2 access token, login cookie or other valid authentication credential. See https://developers.google.com/identity/sign-in/web/devconsole-project.
More details:
Reason: authError, Message: Invalid Credentials

Found Worth Mentioning

When I creating the remote, I remember getting an error Time may be set wrong. I think it was from Google Servers. As the remote worked along with the errors yesterday, I just ignored it.

Something similar to this

Could that be the problem.

It will be a great help, I want to mount my Google Drive. Thanks for your Time and future efforts to help me.

 rclone config reconnect Drive:

Thanks for you Reply, this worked.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.