Http sync or copy failed if the filename too long

What is the problem you are having with rclone?

rclone give not a directory error, I guess because the filename is too long.

I'm trying to make a mirror of http remote. I count all the error path are longer than 300 chars

wget have the same behaviors

Possibly because of max filename length on linux

Any solution for this problem?

What is your rclone version (output from rclone version)

rclone v1.53.1
- os/arch: linux/amd64
- go version: go1.15

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Distributor ID: Ubuntu
Description:    Ubuntu 20.04.1 LTS
Release:        20.04
Codename:       focal

Linux hqsvr 5.4.0-52-generic #57-Ubuntu SMP Thu Oct 15 10:57:00 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync -vvP --http-url "" :http: .

The rclone config contents with secrets removed.

this is just read only http so no config

A log from the command with the -vv flag

2020/10/31 17:17:57 ERROR : *verylongpathhere*: Failed to copy: mkdir *verylongpathherewithlocaldirecotry: not a directory
2020/10/31 17:17:57 ERROR : *verylongpathhere*: Failed to copy: mkdir *verylongpathherewithlocaldirecotry: not a directory

This is a problem with the maximum file name length on linux which is 255 chars for most filing systems.

There are a very few filing systems on Linux which have longer file names, eg ReiserFS.

One thing you could do is copy straight to google drive which can have up to 4k file names.

rclone sync -vvP --http-url "" :http: gdrive:folder
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.