Http Error 403: Signature are not same

What is the problem you are having with rclone?

rclone works well on mac, But not on centos, And I find their signature are not same. the rclone config and version are same. the ceph version is also same

Centos error:
2021/05/28 15:54:32 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2021/05/28 15:54:32 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2021/05/28 15:54:32 DEBUG : HTTP REQUEST (req 0xc00066e400)
2021/05/28 15:54:32 DEBUG : PUT /swj1/copy.go?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=BE6CSGDV55B6LPJ1XSYP%2F20210528%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210528T075432Z&X-Amz-Expires=900&X-Amz-SignedHeaders=content-md5%3Bcontent-type%3Bhost%3Bx-amz-acl%3Bx-amz-meta-mtime&X-Amz-Signature=e90409ea8eff6b4c4ab00411dc0f51a049b6eae0f8e6d160bf444f677f71b406 HTTP/1.1
Host: 10.5.35.229:80
User-Agent: rclone/v1.47.0
Content-Length: 5418
content-md5: Lo7b7sUXTQgbsrLxIwsfQg==
content-type: binary/octet-stream
x-amz-acl: private
x-amz-meta-mtime: 1622182340
Accept-Encoding: gzip

MacOS
2021/05/28 15:51:44 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2021/05/28 15:51:44 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2021/05/28 15:51:44 DEBUG : HTTP REQUEST (req 0xc0000c4400)
2021/05/28 15:51:44 DEBUG : PUT /swj/copy.go?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=BE6CSGDV55B6LPJ1XSYP%2F20210528%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210528T075144Z&X-Amz-Expires=900&X-Amz-SignedHeaders=content-md5%3Bcontent-type%3Bhost%3Bx-amz-acl%3Bx-amz-meta-mtime&X-Amz-Signature=bae898f9caddbf51e1e79de6e732904d1928e83896cd81648ccae84054870932 HTTP/1.1
Host: 10.5.35.229:80
User-Agent: rclone/v1.47.0
Content-Length: 5418
content-md5: Lo7b7sUXTQgbsrLxIwsfQg==
content-type: binary/octet-stream
x-amz-acl: private
x-amz-meta-mtime: 1622182340
Accept-Encoding: gzip

2021/05/28 15:51:44 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2021/05/28 15:51:44 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2021/05/28 15:51:44 DEBUG : HTTP RESPONSE (req 0xc000634100)
2021/05/28 15:51:44 DEBUG : HTTP/1.1 200 OK
Content-Length: 29347
Accept-Ranges: bytes
Connection: keep-alive
Content-Type: binary/octet-stream
Date: Fri, 28 May 2021 07:51:44 GMT
Etag: "f1096206cde662704cbf8bfd654e6c5e"
Last-Modified: Fri, 28 May 2021 06:12:20 GMT
Via: 1.1 cnhk-squid-01 (squid/3.5.20)
X-Amz-Request-Id: tx0000000000000339507fe-0060b0a110-a2d48c6-default
X-Cache: MISS from cnhk-squid-01
X-Cache-Lookup: MISS from cnhk-squid-01:3128

What is your rclone version (output from rclone version)

v1.47.0

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Linux version 3.10.0-957.el7.x86_64 (mockbuild@kbuilder.bsys.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-36) (GCC) ) #1 SMP Thu Nov 8 23:39:32 UTC 2018

macOS Big Sur v11.2.3

Which cloud storage system are you using? (eg Google Drive)

ceph

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

That's a very old version. You'd want to update and retest.

I have tried the version 1.56, It has the same error.

2021/05/31 16:47:22 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2021/05/31 16:47:22 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2021/05/31 16:47:22 DEBUG : HTTP REQUEST (req 0xc000666400)
2021/05/31 16:47:22 DEBUG : PUT /swj1/sync.go?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=BE6CSGDV55B6LPJ1XSYP%2F20210531%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210531T084722Z&X-Amz-Expires=900&X-Amz-SignedHeaders=content-md5%3Bcontent-type%3Bhost%3Bx-amz-acl%3Bx-amz-meta-mtime&X-Amz-Signature=570047b741c98e7af21c17f7f3f1e72adf5961f246ec92b3027502b598fd8af7 HTTP/1.1
Host: 10.5.35.229:80
User-Agent: rclone/v1.56.0-beta.5530.
Content-Length: 831
content-md5: +d7QyBqAd8EZ2kGLu0AbGw==
content-type: application/octet-stream
x-amz-acl: private
x-amz-meta-mtime: 1622113184
Accept-Encoding: gzip

2021/05/31 16:47:22 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2021/05/31 16:47:22 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2021/05/31 16:47:22 DEBUG : HTTP RESPONSE (req 0xc0004b4f00)
2021/05/31 16:47:22 DEBUG : HTTP/1.1 403 Forbidden
Content-Length: 202
Accept-Ranges: bytes
Connection: Keep-Alive
Content-Type: application/xml
Date: Mon, 31 May 2021 08:47:22 GMT
X-Amz-Request-Id: tx0000000000000000077dc-0060b4a29a-300e0a5-default

And I have tried rclone on another ceph, It's endpoint doesn't have 80 port. I try it on macos and centos, It works success.

2021/05/31 16:40:53 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2021/05/31 16:40:53 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2021/05/31 16:40:53 DEBUG : HTTP REQUEST (req 0xc000218c00)
2021/05/31 16:40:53 DEBUG : PUT /test1/copy.go?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=JDUV2AVS0I40BWAVTIY2%2F20210531%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20210531T084053Z&X-Amz-Expires=900&X-Amz-SignedHeaders=content-md5%3Bcontent-type%3Bhost%3Bx-amz-acl%3Bx-amz-meta-mtime&X-Amz-Signature=ca2a031c23ea81341dbef4c82f4508b8f2aa262713a8674b9fe6f9795f36cfde HTTP/1.1
Host: 172.20.20.254
User-Agent: rclone/v1.56.0-beta.5530.
Content-Length: 5418
content-md5: Lo7b7sUXTQgbsrLxIwsfQg==
content-type: application/octet-stream
x-amz-acl: private
x-amz-meta-mtime: 1622113184
Accept-Encoding: gzip

2021/05/31 16:40:53 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2021/05/31 16:40:53 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2021/05/31 16:40:53 DEBUG : HTTP RESPONSE (req 0xc000d1a100)
2021/05/31 16:40:53 DEBUG : HTTP/1.1 200 OK
Content-Length: 0
Accept-Ranges: bytes
Connection: Keep-Alive
Date: Mon, 31 May 2021 08:40:53 GMT
Etag: "ea60fb4095e9fce5c07b7498a532e814"
X-Amz-Request-Id: tx00000000000000000001f-0060b4a115-62a85-default

It's really strange?

Can you share the full command you are running?
Can you share your rclone.conf?

ceph version:
ceph version 12.2.4 (52085d5249a80c5f5121a76d6288429f35e4e77b) luminous (stable)

command:
./rclone -vv copy ./sync/ src:swj1  --dump headers

rclone.conf
type = s3
provider = ceph
access_key_id = 
secret_access_key = 
region = us-east-1
endpoint = http://10.5.41.190:80
acl = public-read-write

I finally make it work by add '--s3-upload-cutoff 0'. But my ceph version is newer than 10.2.x Jewel