How to use log-file in combination with ask_password flag (interactive keyboard)

What is the problem you are having with rclone?

Is it possible to use --log-file together with the ask-password flag (for keyboard interactive authentication)?

I'm trying to rclone copy to an SFTP server that requires the ask-password flag (i.e. no ssh login)

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2-DEV

- os/version: centos 7.9.2009 (64 bit)
- os/kernel: 3.10.0-1160.95.1.el7.x86_64 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.18.3
- go/linking: dynamic
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy /tmp remote:tmp --vv --log-file=mylog.txt

The rclone config contents with secrets removed.

- type: sftp
- host: sftpgw
- user: olferskjf
- ask_password: true
- shell_type: unix

A log from the command with the -vv flag

2023/10/20 16:32:52 DEBUG : Creating backend with remote "testtransfer/"
2023/10/20 16:32:52 DEBUG : Using config file from "/home/olferskjf/.config/rclone/rclone.conf"
2023/10/20 16:32:52 DEBUG : fs cache: renaming cache item "testtransfer/" to be canonical SOURCE
2023/10/20 16:32:52 DEBUG : Creating backend with remote DESTINATION
Enter SFTP password: (base) olferskjf@nodelogin01 ~ $

welcome to the forum,

why not give it a try?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.