How to update to new version?

I tried searching for this in the docs and forums, but didn’t have much luck. I’m pretty new to command line/linux and don’t want to screw anything up.

I’m currently running rclone 1.34, but want to update to 1.35. How do I actually install the new version and replace the old one? I could really use a step by step guide.

Its just a file so download it from here: and replace existing one.

Linux step by step

cp ./ /usr/bin/

btw if you have mount running unmount it or just
killall -9 rclone
and then above steps / dont forget to remount your drives.

type rclone version to see if you have latest one

p.s. If you dont have killall command install it with apt-get install psmisc

1 Like

So I tried this, using the same directions as the original install.

Fetch and unpack

curl -O
cd rclone-*-linux-amd64
Copy binary file

sudo cp rclone /usr/sbin/
sudo chown root:root /usr/sbin/rclone
sudo chmod 755 /usr/sbin/rclone
Install manpage

sudo mkdir -p /usr/local/share/man/man1
sudo cp rclone.1 /usr/local/share/man/man1/
sudo mandb

When I rclone --version, it still gives me 1.34 after a reboot.

Ahh, i responded before the steps. Lemme try again.

you have rclone running make sure its not before you copy it.

ps aux | grep rclone

p.s. You dont need to bother with manpage or chown etc…

cp ./ /usr/bin/

gives me the error:
cp: cannot stat ‘./’: Not a directory

When I change it to:

cp ./rclone-v1.35-linux-amd64/rclone /usr/bin/

It gives me the error:

cp: cannot create regular file ‘/usr/bin/rclone’: Permission denied

I think I got it now. I adjusted the last step to:

sudo cp ./rclone-v1.35-linux-amd64/rclone /usr/sbin/

And it reports the correct version now.

btw check you dont have rclone in /usr/bin and /usr/sbin use just one location whichever you prefer.

eg sudo rm /usr/sbin/rclone if you had old version there.

What are the steps for windows? Just replace the one file?


p.s. For 20 char limitation :slight_smile:

I am having the same issue. I used the following commands:

cp ./ /usr/sbin/

I’ve encountered no errors but when I check for the version it still shows as 1.34. Any ideas?

type which rclone to see the location.

p.s. Before copying new version you should kill all instances (incuding mount ) eg type ps aux | grep rclone to see whats running followed by killall -9 rclone then do copy.

Thanks for the info Ajki. I see the rclone location is the issue. rclone was already installed on my seedbox from Ultraseedbox. I see it’s installed at /usr/local/bin/rclone. However, I do not have permission to write to that folder. Do you think I should ask them to update? or could I install under my account, /home15/MyProfileName/usr/sbin. Do you know if the two would conflict?

or just always put a path in front of your rclone command eg /usr/sbin/rclone mount/copy/move

ok, perfect… Thanks :slight_smile: