How to speed up downloading to OpenDrive?

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

My problem is that I store my files on OpenDrive, however when I come to download a file, it's totally slow, can you please help me?

Run the command 'rclone version' and share the full output of the command.

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount opendrive: O: --vfs-cache-mode full -vv --multi-thread-streams 0 --cache-dir C:\rclonecache


as compared to what?

try increasing --transfers, chunk size and for non-mount commands, --checkers

How do I increase transfers and checkers? Do you have a procedure?

not really, try different values, see what happens. check the documentation for the various flags.
note: checkers do not work on mount

fwiw, might get better performance with rclone copy

j'ai testé plusieurs valeurs et je télécharge toujours à 250mbit/s, vous savez si OpenDrive peux aller plus vite en téléchargement

Is my method for mounting the player the right one to ensure a good, fast and stable connection, because often when I play a video remotely after 30 minutes, rclone slows down and thus causes a slowdown, even blocking of the video files:

rclone mount opendrive: O: --vfs-cache-mode writes -vv --ignore-checksum --multi-thread-streams 0 -o blocksize=1048576 --async-read=false --debug-fuse --drive-chunk-size 512M --max-backlog 999999 --fast-list --transfers=45 --checkers=45

well, the command has a lot of issues.
if not 100% sure what a flag does, then do not use it, just use default values.
and then test again.

please give me a mount control that works very well and has a fast speed

I redid the basic command leaving --allow-non-empty

It looks fast, but what else can I add for transfers and direct download to make it faster?

sorry, hard to help, so far, you have not posted the redacted config, rclone version or a debug log.

as i have already mentioned, have a few options.
try the simplest command possible, test it, add/change/remove flags/values and test again and again.
in that way, you can figure out what the best speed is for your system, internet and provider.

start with rclone mount opendrive: O: -vv

in addition, the forum is full of discussions about optimizing mount commands.

OpenDrive is slow. You can optimize whatever this service is compared to google or dropbox just slow.

This is my mount command :

rclone mount opendrive: P: --vfs-cache-mode writes -vv --cache-dir C:\rclonecacheplexserver --allow-non-empty --bwlimit 6.25M --allow-other --dir-cache-time 72h --drive-chunk-size 64M --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off

wtf that makes no sense........

-vv is for debugging
--bwlimit .. limit your speed
--drive-chunk-size is for google drive ...

try this command:

rclone mount opendrive: P: --vfs-cache-mode writes --cache-dir C:\rclonecacheplexserver --allow-non-empty --allow-other --dir-cache-time 72h --attr-timeout 24h --poll-interval 30s --opendrive-chunk-size 64M --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 512M --transfers 8

Why vfs cache mode Writes ?
Vfs cache mode full is not good ?

Why not? full is also possible. I dont know what you want to do. Is it faster with my command?

As @asdffdsa already suggested why don't you try simple mount command with default options? Using random flags is not a solution... Especially when some of them are google drive ones.

Your mount command is bizzare...

--dir-cache-time 72h --attr-timeout 24h

Any reason you use different times here for example? Does it have any logical purpose?

Hello everyone,

I made this command and it seems to work pretty well, sorry for all the questions, I'm trying to understand how rclone works :

rclone mount opendrive: O: --vfs-cache-mode full -vv --cache-dir C:\rclonecache --opendrive-chunk-size 64M --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 512M --transfers 8

thank you

1 Like

Hello, I'm coming back to you after several days of tests on the line you gave me, at first it was good but then everything slowed down again, do you have another order to offer me so that it goes faster please?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.