How to set the default permission for rclone sync (remote to local)?

What is the problem you are having with rclone?

I'm doing rclone sync [google drive] [local] on raspberry pi. My local drive is formatted as Ext4. I noticed that all the downloaded files have their permission set to 644. I want them to be executable as 744 so they can be executed on my windows pc. Is there a way to configure rclone to override the permission of the synced files?

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Raspbian GNU/Linux 10 (buster)

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync google-drive: "/media/pi/foo/bar" --fast-list --transfers=8 --max-backlog=300000 --buffer-size=128M

The rclone config contents with secrets removed.

type = drive
client_id =
client_secret =
scope = drive
token =
skip_gdocs = true
upload_cutoff = 128M
chunk_size = 128M
acknowledge_abuse = true
root_folder_id =

A log from the command with the -vv flag

On your Linux box, that is defined by the umask:

felix@gemini:~/test$ umask 000
felix@gemini:~/test$ touch test1
felix@gemini:~/test$ umask 022
felix@gemini:~/test$ touch test2
felix@gemini:~/test$ rclone copy GD:hosts .
felix@gemini:~/test$ ls -al
total 12
drwxrwxr-x  2 felix felix 4096 Jan 13 16:37 .
drwxr-xr-x 20 felix felix 4096 Jan 13 16:36 ..
-rw-r--r--  1 felix felix  225 Dec 14 08:10 hosts
-rw-rw-rw-  1 felix felix    0 Jan 13 16:37 test1
-rw-r--r--  1 felix felix    0 Jan 13 16:37 test2

Not sure how that translates to your Windows PC executable, but in general on Linux, you have to set something executable as you can't default it.

1 Like

Thank you so much!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.