How to set local path in the rclone.conf

Hi,

I'm trying to locate the exact command I need to use in order to indicate where my local sync should take place so that when I sync to dropbox, I don't have to specify the exact path everytime I use the rclone sync command.

How do I set my local path for say /home/stress/Dropbox within the rclone.conf so that this is possible?

I did do a search but couldn't find anything which indicated this was the topic of discussion.

I'm using FreeBSD 13.1

Thank you for your help in advance,

StressTest

Hi, welcome to the forum!

I think creating an alias remote is what you are looking for?

If you create one using rclone config interactive command, as I assume you have done already for your Dropbox, then you will have something like this in your rclone.conf:

[home]
type = alias
remote = /home/stress/Dropbox

[cloud]
type = dropbox
app_key =
app_secret =
token = XXXXXXXXXXXXXXXXXXXXXXXXXXXXX_XXXX_XXXXXXXXXXXXXXXXXXXXXXXXXXXXX

And you can use them like this:

rclone copy home: cloud: --dry-run

Thank you for your reply.

I tried what you suggested and it appears to be running but it's not transferring files, the Elapsed time just keeps chugging away without any files ever being transferred. I disabled my firewall as it was preventing me from even getting my token key from dropbox, but it's still completely open now and so it's not a firewall issue.

Any ideas of why it wouldn't be transferring any of my files?

Here's the command I issued and the screen content before I killed the process:

rclone sync home: cloud: -P
2022-08-04 17:55:19 NOTICE: too_many_requests/.: Too many requests or write operations. Trying again in 300 seconds.
2022-08-04 17:55:19 NOTICE: too_many_requests/...: Too many requests or write operations. Trying again in 300 seconds.
2022-08-04 18:17:43 NOTICE: too_many_requests/.: Too many requests or write operations. Trying again in 300 seconds.
Transferred:              0 B / 0 B, -, 0 B/s, ETA -
Elapsed time:     23m26.5s

Appreciate any insight that may help get this figured out.

Here is my rclone.conf:

[cloud]
type = dropbox
chunk_size = 100Ki
token = {"access_token":"XXXXXXXXXXXXXXXXXXXXXXXXX","token_type":"bearer","refresh_token":"XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX","expiry":"2022-08-04T21:10:04.861003608-07:00"}

[home]
type = alias
remote = /home/stress/Dropbox

Thanks...

OK, I figured it out... Sometimes I get in my own way...

I should have been running:

rclone sync cloud: home: -P

and not:

rclone sync home: cloud: -P

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.