How to reduce timeout

What is the problem you are having with rclone?

Hello, we don't know why but to put files on a sftp serveur, we need to connect 3 times, and on the third time it's OK!! (we will try to correct that).

So the time of transfert is about 10min and 20s, We suppose that :
connection -> wait of 5min -> retry connection -> wait of 5min -> retry connection -> OK -> transfer about 20s

How can I reduce the 5min timout to retry the connection?

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Centos 7.9, 64bits

Which cloud storage system are you using? (eg Google Drive)

Private sftp

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone move -Pvvv /data/IMPORT_OCTANT/ pemps:rep/PIDSA_NEW/DTG-DME/IMPORT_OCTANT/ --no-update-modtime --timeout 1m --contimeout 10s

The rclone config contents with secrets removed.

A log from the command with the -vv flag

Quiconque accéderait ou tenterait d'accéder à ce système, sans
y avoir été autorisé expressement et ce, en toute connaissance de cause, -ou
encore qui s'y maintiendrait après y être entré involontairement -
s'exposerait aux sanctions prévues a l'article 323-1 du Nouveau Code
Penal, soit deux ans d'emprisonnement et 30 000 Euros d'amende.

2021/01/14 10:46:38 DEBUG : rclone: Version "v1.52.0" starting with parameters ["rclone" "move" "-Pvvv" "/data/IMPORT_OCTANT/" "pemps:rep/PIDSA_NEW/DTG-DME/IMPORT_OCTANT/" "--no-update-modtime" "--timeout" "1m" "--contimeout" "10s"]
2021/01/14 10:46:38 DEBUG : Using config file from "/home/jenkins/.config/rclone/rclone.conf"
2021/01/14 10:46:38 DEBUG : s New connection> to "SSH-2.0-mod_sftp"

2021-01-14 10:46:38 DEBUG : ATM01_TFX.csv: Sizes differ (src 48929 vs dst 50753)
Transferred: 0 / 0 Bytes, -, 0 Bytes/s, ETA -
Checks: 0 / 2, 0%
Elapsed time: 0.0s

  •                             ATM01_TFX.csv: checking

It looks like you've set the correct parameters...

You could try setting --low-level-retries lower, but I'm not sure that will make a difference.

Can you try the latest rclone to see if that is any different?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.