How to not force syncing of local file when cloud file is more recent?

Using RClone on a fresh new ubuntu 23.10 in order to connect to my Onedrive cloud service. Everyhting runs ok and integrates well with Nautilus on Gnome, but for one VERY important thing.

When a remote file has been updated (via the onedrive web interface for example), while my computer is off, and I open my computer... then the old local file is pushed to the cloud, deleting the more recent one.

Is it possible to tell Rclone not to do that? Rclone Sync -u seems to be the answer, but I don't know how/where to edit it... ? (I checked this page: rclone sync).

rclone v1.60.1-DEV
- os/version: ubuntu 23.10 (64 bit)
- os/kernel: 6.5.0-14-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.0
- go/linking: dynamic
- go/tags: none

Which cloud storage system are you using?

Ms Onedrive

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

rclone config
Current remotes:

Name                 Type
====                 ====
Onedrive             onedrive

welcome to the forum,

add it to the rclone command. can safely test using --dry-run

and that is an old version of rclone, can update using rclone selfupdate

1 Like

Thanks for the fast answer... I'm not used to terminal commands so I feel dumb as hell but how do I "add it to the rclone command"?

When my systems starts, the following command is in my startup utility:

sh -c "rclone --vfs-cache-mode writes mount \"Onedrive\": ~/OneDrive"

Am I supposed to add sync -u somewhere inside this command?

About the selfupdate command, I get this error message from the terminal:

~$ sudo rclone selfupdate
2023/12/13 15:00:49 Error: failed to update rclone: invalid hashsum signature

just add the flag to the command same as any flag, same as you added --vfs-cache-mode
sh -c "rclone --update --vfs-cache-mode writes mount \"Onedrive\": ~/OneDrive"

note: i do not know if --update works with mount

Thanks a lot, I'll try it!

yeah, that is a known problem.

unintall the current rclone and then run
sudo -v ; curl | sudo bash

fwiw, just in case, backup the rclone config file beforehand.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.