How to move rclone to a new pc? (the remote drive isn't changing)

What is the problem you are having with rclone?

I have built a new PC and want to move my rclone access to my google drive from my current pc to the new one. I am wondering if there is any specific way to do this, do I need to go through the whole process of installing rclone on the new machine as if for the first time or is their some other migration proceedure? There will ne no changes to my remote drive.

I am currently using Rclone Version 1.53.1

hi,

what is the full output of rclone version

basically

  1. install latest rclone on new machine v1.60.1
  2. copy config file from old to new.
    rclone config file

Hi thanks for replying, so do you mean I will need to install Rclone on the new machine using this guide: Google drive
Then puting the config file / folder from my old pc into my user folder on the new machine? I can't even run the Cmd on this old machine at the moment it is so slow now. I will try that in the morning after a reboot.

i guess you did not post the full output of rclone version.
so i do not know what operating system you are using and thus hard to give good advice.

so i have to assume that you are running microoft windows.
if that is correct, then

  1. download rclone from https://rclone.org/downloads/
  2. find the config file by running rclone config file
rclone config file
Configuration file is stored at:
C:\Users\user01\AppData\Roaming\rclone\rclone.conf
  1. copy the rclone.conf from the old machine to the same location on the new machine.

Ok I am on the new PC now and have moved the config file over exactly as you say.

When I go into rclone it shows my existing remote as I had it on the old pc
Name Type
==== ====
kino drive

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q>

I seem to be unable to get beyond this bit as I keep getting an error when rclone tries to go to google for authentication. I am getting this error:

"Access blocked: rclone’s request is invalid
You can’t sign in because rclone sent an invalid request. You can try again later, or contact the developer about this issue. Learn more about this error
If you are a developer of rclone, see error details.
Error 400: invalid_request"

Details:

Error 400: invalid_request

The loopback flow has been blocked in order to keep users secure. Follow the Loopback IP Address flow migration guide linked in the developer docs below to migrate your app to an alternative method.

I was just using the old google api client ID and secret in the old config.

I also tried to mount the drive using rclone mount kino: x: and was prompted to run rclone config reconnect kino: but I just get the same error whe rclone tries to connect to google the invalid request error: Error 400: invalid_request as above.

Here is the full output for rclone on my new pc:

rclone version
rclone v1.60.1

  • os/version: Microsoft Windows 11 Pro 22H2 (64 bit)
  • os/kernel: 10.0.22621.819 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.19.3
  • go/linking: static
  • go/tags: cmount

This is the output of rclone version from my old pc:

c:\rclone>rclone version

rclone v1.53.1

  • os/arch: windows/amd64

  • go version: go1.15

I am not sure how to get round this error from google, I've seen various posts saying to use the latest version of rclone which I am on this new pc and I'm still having issues. Do I need to star again from scratch and make a new client id and secret?

Thanks for your help!

post the full output of
--- rclone config show kino: -vv
make sure to redact id/secrets/tokens
--- rclone lsd kino: -vv
ok to redact the name of the folders.

try to enclose the text with three backticks so it is formatted like this.

[gdrive01]
type = drive
client_id = redacted
client_secret = redacted
scope = drive
token = redacted
root_folder_id = redacted
[kino]
2022/11/21 16:45:37 DEBUG : Using config file from "C:\\Users\\souse\\AppData\\Roaming\\rclone\\rclone.conf"
type = drive
client_id = redacted
scope = drive
client_secret = Redacted
2022/11/21 16:45:37 DEBUG : rclone: Version "v1.60.1" finishing with parameters ["C:\\rclone\\rclone.exe" "config" "show" "kino:" "-vv"]```

When I ran rclone config show kino -vv

```2022/11/21 16:48:49 DEBUG : rclone: Version "v1.60.1" starting with parameters ["C:\\rclone\\rclone.exe" "lsd" "kino:" "-vv"]
2022/11/21 16:48:49 DEBUG : Creating backend with remote "kino:"
2022/11/21 16:48:49 DEBUG : Using config file from "C:\\Users\\souse\\AppData\\Roaming\\rclone\\rclone.conf"
2022/11/21 16:48:49 Failed to create file system for "kino:": drive: failed when making oauth client: failed to create oauth client: empty token found - please run "rclone config reconnect kino:"*emphasized text*```

recently, google changed the oauth process

need to run
rclone config reconnect kino:

I set up a new remote to the same google drive called Kino2 where I did not add my own client id or secret and just left it at the default and that worked, however I believe it is better to have your own client id and secret. I have read that google changed something on their end in October 2022 which is causing these issues. I saw this post Google Drive - Error 400: invalid_request when access url to for Log in and authorize rclone for access - #3 by myfrogtees and wondered if I am having a similar issue?

Sorry I think I got the formatting you requested wrong.

see my last post.....

I did that earlier and said in an earlier post (sorry my formatting is confusing) however when I do run

rclone config reconnect kino:

Rclone attemtps to ask google for permission and I get the same error as before:

"Access blocked: rclone’s request is invalid
You can’t sign in because rclone sent an invalid request. You can try again later, or contact the developer about this issue. Learn more about this error
If you are a developer of rclone, see error details.
Error 400: invalid_request"

That command isn't working for me.

not sure, not a gdrive expert, might be a browser issue.

post the full output of this, redact id/secret/token
rclone config reconnect kino: -vv
it should open a browser windows, post a screen snippet of the text.

or

perhaps, as test, create a new remote, and not use client_id/secret

and if that does not work, then i think we have enough info for someone else to comment.

This is what happens when I run rclone config reconnect kino:

PS C:\Users\xxxx\Desktop> rclone config reconnect kino:
Use auto config?

  • Say Y if not sure
  • Say N if you are working on a remote or headless machine

y) Yes (default)
n) No
y/n> y

2022/11/21 17:02:38 NOTICE: Make sure your Redirect URL is set to "http://127.0.0.1:53682/" in your custom config.
2022/11/21 17:02:38 NOTICE: If your browser doesn't open automatically go to the following link: http://127.0.0.1:53682/auth?state= redacted?
2022/11/21 17:02:38 NOTICE: Log in and authorize rclone for access
2022/11/21 17:02:38 NOTICE: Waiting for code...

At this point rclone goes to google for authentication and that is when I get the error:

"Access blocked: rclone’s request is invalid
You can’t sign in because rclone sent an invalid request. You can try again later, or contact the developer about this issue. Learn more about this error
If you are a developer of rclone, see error details.
Error 400: invalid_request"

I did create a new remote which was "Kino2" and I didn ot use client_id/secret and that does work. It does seem to be an issue with the client _id / secret.

i would create a new client_id/secret and use that with Kino2

PS C:\Users\xxxx\Desktop> rclone config reconnect kino: -vv
2022/11/21 17:34:30 DEBUG : rclone: Version "v1.60.1" starting with parameters ["C:\rclone\rclone.exe" "config" "reconnect" "kino:" "-vv"]
2022/11/21 17:34:30 DEBUG : Using config file from "C:\Users\xxxxx\AppData\Roaming\rclone\rclone.conf"
2022/11/21 17:34:30 DEBUG : kino: config in: state="", result=""
2022/11/21 17:34:30 DEBUG : kino: config out: out=&{State:*oauth,teamdrive,, Option: OAuth: Error: Result:}, err=
2022/11/21 17:34:30 DEBUG : kino: config in: state="*oauth,teamdrive,,", result=""
2022/11/21 17:34:30 DEBUG : kino: config out: out=&{State:*oauth-confirm,teamdrive,, Option: OAuth: Error: Result:}, err=
2022/11/21 17:34:30 DEBUG : kino: config in: state="*oauth-confirm,teamdrive,,", result=""
2022/11/21 17:34:30 DEBUG : kino: config out: out=&{State:*oauth-islocal,teamdrive,, Option:true OAuth: Error: Result:}, err=
2022/11/21 17:34:30 DEBUG : kino: config: reading config parameter "config_is_local"
Use auto config?

  • Say Y if not sure
  • Say N if you are working on a remote or headless machine

y) Yes (default)
n) No
y/n> y

2022/11/21 17:34:42 DEBUG : kino: config in: state="*oauth-islocal,teamdrive,,", result="true"
2022/11/21 17:34:42 DEBUG : kino: config out: out=&{State:*oauth-do,teamdrive,, Option: OAuth: Error: Result:}, err=
2022/11/21 17:34:42 DEBUG : kino: config in: state="*oauth-do,teamdrive,,", result=""
2022/11/21 17:34:42 NOTICE: Make sure your Redirect URL is set to "http://127.0.0.1:53682/" in your custom config.
2022/11/21 17:34:42 DEBUG : Starting auth server on 127.0.0.1:53682
2022/11/21 17:34:42 NOTICE: If your browser doesn't open automatically go to the following link: http://127.0.0.1:53682/auth?state=
2022/11/21 17:34:42 NOTICE: Log in and authorize rclone for access
2022/11/21 17:34:42 NOTICE: Waiting for code...
2022/11/21 17:34:42 DEBUG : Redirecting browser to: Anmelden – Google Konten

Sorry this is the full output with the -vv at the end, I forgot that the first time

Thanks, I'd like to jsut keep the name kino for the drive. Is it possible to just delete Kino2 and make a new client_id/secret as you suggest and make a new remote on the new PC called kino with those details?

Also If I delete a remote in the config it won't delete my files will it?

Thanks again.

as i suggested before, create a new client_id/secret and then create a new remote using that.

then rename the remote using rclone config

correct

other than that, i think we will have to wait for another rcloner to comment.

1 Like

Hi ok I did that and it is working now as it should be. Just struggling to get the drive mounted automatically on start up. I did use NSSM on my old machine but that doesn't seem to be working on this machine / windows 11. Will keep trying to find a way to make this work.

good

can use task scheduler

image

1 Like