How to mount to a NAS server

Thank you for your patience as I'm really new to rclone. I'm trying to mount rclone onto an NAS server I have at my house. I have a WD My Cloud EX2 Ultra. I have set up a shared folder on the NAS and have mapped a drive to it's file location (z:). Just to try to get it to work, the drive is a public drive that doesn't have any passwords to get into it. I've tested mounting and here is an example that does work on my computer:

rclone mount --vfs-cache-mode full gDrive:/ g:

I've also been able to mount to my local hard drive with the same command, like:

rclone mount --vfs-cache-mode full gDrive:/ c:/testFolder

The "testFolder" doesn't actually exist yet and rclone creates the folder for me.

However, when I try to mount to the mapped network drive that goes to my WD NAS, it gives me an error.
The command looks like

rclone mount --vfs-cache-mode full gDrive:/ z:/testFolder

where z: is the mapped drive.
The error says:
Fatal error: failed to mount FUSE fs: parent of mountpoint directory does not exist: z:\testFolder

So I don't get why I can use the command to mount to one drive (c:) and simply changing the drive letter to a drive that is mapped (z:) will give me an error.

I've also tried the command:

rclone mount --vfs-cache-mode full gDrive:/ \\MYCLOUDEX2ULTRA\googledrive\testFile

That does work in the sense of having a successful mount, but it will create a new network drive "y:" and isn't mounted to the actual NAS mapped folder (z:)

By the way, I have actually tried to install rclone onto the WD Mycloud NAS by following someone's example online of getting PuTTY and going through the SSH. I followed the set of instructions I found online and I couldn't install rclone on the NAS. The first direction of

C:\Windows\System32\cmd.exe /k ssh -oHostKeyAlgorithms=+ssh-dss root@`yourwdmycloudaddress

that I seemed to not do correctly. I copied it from this forum: Rclone on MyCloud Mirror - My Cloud 3rd Party & Mobile Apps - WD Community
If there's an updated version on how to do this with Mycloud, that would be great too.

Please help with ideas or suggestions and if you could dumb them down for me somewhat and assume I'm not a brilliant computer guy, I'd appreciate it.

I just installed rclone so I know I've got the latest version. I also downloaded and installed the latest version of WinFsp. I'm assuming this is all working as I can mount it on my local hard drive.

I've been primarily using Windows 7 64bits. I do have a Windows 10 computer, but assume it's not necessary as I'd like my Windows 7 computer to be the one that is always on with the mount going.

Pulling data from google drive.

hello and welcome to the forum,

I have a client with a wdnas.
over vpn, i was able to install rclone onto it.

  1. ssh into nas, make sure you have enabled ssh in the web interface.
  2. do the standard rclone on install
    curl | sudo bash
root@WDMyCloudMirror ~ # rclone version
rclone v1.56.0
- os/version: unknown
- os/kernel: 4.14.22-armada-18.09.3 (armv7l)
- os/type: linux
- os/arch: arm
- go/version: go1.16.5
- go/linking: static
- go/tags: none

on windows, to ssh into a device, i use bitvise ssh client, free, builtin sftp client, GUI - no need for command line...

rclone mount works

2021/08/23 11:14:17 DEBUG : rclone: Version "v1.56.0" starting with parameters ["rclone" "mount" "remote:" "/mnt/HD/HD_a2/asdffdsa" "--read-only" "--no-checksum" "--rc" "--rc-addr=:6001" "--no-modtime" "--dir-cache-time=10000h" "--attr-timeout=10000h" "--buffer-size=300M" "--allow-other" "--log-level=DEBUG" "--log-file=/home/root/rclone/scripts/log.remote.txt"]
2021/08/23 11:14:17 NOTICE: Serving remote control on
2021/08/23 11:14:17 DEBUG : Creating backend with remote "remote:"
2021/08/23 11:14:17 DEBUG : Using config file from "/home/root/.config/rclone/rclone.conf"
2021/08/23 11:14:17 DEBUG : Creating backend with remote "seedboxio_sftp_internet:"
2021/08/23 11:14:18 DEBUG : s New connection>x.x.x.x:22 to "SSH-2.0-mod_sftp"
2021/08/23 11:14:18 DEBUG : s Using absolute root directory "/"
2021/08/23 11:14:18 DEBUG : fs cache: renaming cache item "remote:" to be canonical "seedboxio_sftp_internet:"
2021/08/23 11:14:18 INFO  : s poll-interval is not supported by this remote
2021/08/23 11:14:18 DEBUG : s Mounting on "/mnt/HD/HD_a2/asdffdsa"

to share that rclone mount from the wdnas to the lan.

  1. using wdnas web interface, create a share. in my example it is called asdffdsa
  2. on the wdnas file system, find the location of the file share. in my example, /mnt/HD/HD_a2/asdffdsa
  3. on the windows computer, net use x: \\wdnas\asdffdsa /user:username password /persistent:yes
dir x:\files\done
 Volume in drive X is asdffdsa
 Volume Serial Number is 980C-68A0

 Directory of x:\files\done

08/21/2021  05:10 PM    <DIR>          .
08/22/2021  12:29 PM    <DIR>          ..
07/15/2021  06:53 PM    <DIR>          audio
08/21/2021  05:10 PM    <DIR>          books
08/22/2021  04:46 PM    <DIR>          movies
08/04/2021  08:08 PM    <DIR>          tv
  1. be happy

Hi jojo, thanks for the response. Let me share how far I've been able to get. I downloaded the bitvise and logged into the nas with the ssh. I clicked on the icon on the left "New terminal console" which brought up the command prompt type screen. From there I typed what you wrote:

curl | sudo bash

It looked like it was starting a download. However near the end of the progress, it halted by saying
"cp: error writing '/usr/bin/': No space left on device"

That's not true since I have over 500 gb left on it. If I try to run the same command again, it will say
"tmp_unzip_dir_for_rclone/rclone-v1.56.0-linux-arm/rclone: write error (disk full?). Continue? (y/n/^C)
warning: tmp_unzip_dir_fir_rclone/rclone-v1.56.0-linux-arm/rclone is probably truncated"

If I run it for a third time it will simply say
"Failed writing body (4313 != 4744)"

If I reset my NAS and try it again, it'll repeat these errors. By the way, I don't know if the type of Mycloud makes a difference. I see yours says WDMyCloudMirror while mine says MyCloudEX2Ultra.

I did try following the other guy's instructions (Rclone on MyCloud Mirror - #4 by Schweinshaxe - My Cloud 3rd Party & Mobile Apps - WD Community) for downloading it onto the NAS, which was successful, including unzipping it and doing the

ln -s /mnt/HD/HD_a2/Nas_Prog/rclone-v1.53.2-linux-arm-v7/rclone  /bin/rclone

command. When I then type "rclone config" it says "Segmentation fault"

I hate to admit, but your second post that says "rclone mount works..." looked all foreign to me and I didn't understand anything that was included in that post. Is that some sort of platform you type all those lines in, verbatim? I wasn't sure what the timestamps were all about either. I'm guessing your 3rd response is dependent on the 2nd response so with my lack of deep knowledge into this stuff, I think I'd need some extra help on your second response in what you meant.

So as of right now, I know I have rclone downloaded and unzipped in the following location on the NAS


But I can't seem to run rclone config.

sorry, i am not a linux expert and i really do not like wdnas products
no idea the differene between models.

that latest can be download from

Segmentation fault
what is the output of uname -a?

perhaps you downloaded the incorrect version based on your cpu architecure.
i would download all three versions of rclone for ARM, try each one.

I don't know if you've had this experience, but after doing a few different things and then going back to try to do the rclone config, I actually got it working. I have no idea what actual step I tried that was the solution, but I've got it working.

The issue I'm having now is after run the rclone mount, I'll go into Plex to add a folder, but then after a minute or two it seems everything crashes and I need to reset the NAS, which is annoying because I have to start all over by doing the rclone config and creating the drive again. Plus, I can see how this would be an issue should the NAS decide to do an update of its own and need to restart.

So here's the mount command I used:

rclone mount remote: /mnt/HD/HD_a2/googledrive --read-only --no-checksum --rc --rc-addr=:6001 --no-modtime --dir-cache-time=10000h --attr-timeout=10000h --buffer-size=300M --allow-other --log-level=DEBUG --log-file=/home/root/rclone/scripts/log.remote.txt

I practically copied and pasted your line you used, using my own folder instead of the asdffdsa. I tried opening a GUI (which I'm still ignorant on how to use) but I couldn't figure it out. So I typed it in the command prompt style page of Bitvise. The mount worked and I could see my google drive files mounted in the /mnt/HD/HD_a2/googledrive folder. But again, once I started having Plex read what files were in there, everything seemed to crash and I need to restart the NAS.

To answer one of your questions, when I type uname -a, I get:

Linux MyCloudEX2Ultra 4.14.22-armada-18.09.3 #1 SMP Mon Dec 21 02:42:49 UTC 2020 ga-18.09.3 Build-24 armv71 GNU/Linux

I'm not sure if that's relevant anymore since I can do the rclone config now.

I'm making progress and am so grateful for your help. Any thoughts up to where I'm at?

are you running plex on the wdnas ?
another computer accessing the files over the lan?

one issue could be lack of memory, common to many nas.
perhaps remove --buffer-size=300M

It does run off of the NAS directly. I'll give your suggestion a shot. Thanks.

It looks like that little trick did the job! Plex is updating the folders and has continued to do so for the past 30 minutes. It looks like it should probably continue without any issues! Thank you!!!

Since you have a wdnas, how do you deal with rclone when the server reboots, like after an update? For me, I have to start the whole rclone config all over again and then mount it. Any way to just make this happen automatically should the wdnas reboot so I don't have to do it every time?

good, it is working, that wdnas has just 1GB memory.

i do not use wdnas, cannot be trusted.
i have a client that has one.
to help you out, one time, for a few minutes, i vpn into that wdnas, installed rclone and setup a mount.

at this point, best to join the wdnas forum, and ask such questions there.
a quick internet search indicates cron is supported.

Hi @asdffdsa,

I admire your commitment to help and test things out for fellow rcloners; even if you haven’t tried yourself before.

In this specific situation and all friendliness, I do however think that you should give @codini1 a bit more information to understand why you think her/his wdnas cannot be trusted. I guess it depends on use case, accessibility from the internet, etc.

well, i was do to remote into that site at some point soon and check some logs...

since you asked.

  • most wdnas have two drives, not three. cannot be trusted for data. perhaps if only storing non-critical data.
    the monkey side of me, always find it strange that humans are ok with that.
  • the wd apps for windows are not good and recently some have been deprecated.
  • if the goal is plex, i currently use jellyfin on a cheap raspberry pi or in the past, an old used computer.
  • limited set of apps that will run on the wdnas as compared to a synbox or qnas.
  • kinda, sorta, just enough linux to be oh so frustrating.
    i am linux lightweight, i can get things working with some good documentation, but very hard for me to workaround issues.

Thanks, this gives a much better understanding.

I sure can relate to this, and guess it is using BusyBox. I have found this list of available commands and parameters very useful: BusyBox - The Swiss Army Knife of Embedded Linux

for me, my primary use-case is a backup server.
and for that have not found the need for linux.

i had done very well taking a cheap and/or used computer, installing the free, awesome windows server 2019 hyper-v edition.
add a some hard drives, which would be needed for any nas. formatted with REFS - windows version of ZFS.

using free veeam agent on desktops and free veeam backup and replication for the backup server.

i have a python script that runs on the backup server that orchestrates 7zip, fastcopy, veeam and of course rclone using VSS.
wasabi s3 for recent backups and aws s3 deep glacier for older backups

You're probably right and I'll head over to wdnas forums to see if there's any info already out on it. Thank you again for your help. I'll admit most of what you wrote was educational for me as this is the first time I've ever done anything with linux and am relatively ignorant and uneducated on most IT issues. So thank you again for getting me on track.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.