How to mount a personal Jottacloud as a drive on Win10?

What is the problem you are having with rclone?

Hi, im new to rclone, and also new to understand rules of this forum. I hope i make myself clear and get some help from you experts.

Thanks up front.

I need help to make a command/script to autorun on my Win10 computer.
I want to se my jotta backup on drive J:

The Idea is to compare my backup on Jotta to my live NAS. Reason is that jotta grows each time i backup a local fil/dir, if i delete locally or rename directory jotta dont syncronize (and I dont want it to syncronize). Due to this my jottacloud storage is bigger than needed, but also a bit crappy. (i started to use jotta in 2012, no cleaning has happened after that, so i have like 24 GiB, NAS is 10 GiB).

Local computer has a mounted NAS on drive M:
m:\ (Mynas root folder)

ie: Local i have files stored like:

On Jottacloud I navigate in web view
BackedUp> VAIO \ M
BackedUp> VAIO \ M \Work
BackedUp> VAIO \ M \Private
BackedUp> VAIO \ M \Children

What is your rclone version (output from rclone version)

rclone: Version "v1.53.3"

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Win10 64 bit

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount --allow-other --daemon

I have googled and found this suggestion 
rclone mount --allow-other --daemon

But I need help to incorporate local and remote

Under is a idea, not a correct syntax to mount remote M:Mynas to J: drive loccal

rclone mount J: = VAIO \ M \ *.* --allow-other --daemon

The rclone config contents with secrets removed.

Paste config here

type = jottacloud
client_id = jottacli
client_secret =
tokenURL = htt p s://id. auth /realms/jottacloud/protocol/openid-connect/ token
token = {"access_token":"xxxx","expiry":"2021-xx-xxT08:25:09.x0x0x0x+04:00"}
configVersion = 1

A log from the command with the -vv flag

I did not make a log, there is nothing at this time


hello and welcome to the forum,

these do nothing on windows, so you can remove them

  • -allow-other
  • --daemon

the mount should look like this, the J: will appear in windows explorer.
rclone mount Jotta J:

to copy files, you can use windows explorer, second copy, robocopy or any number of file copy tools.
if you copy a file to J:, then rclone will be copied to Jotta.

to backup files, use rclone sync or rclone sync instead of rclone mount
and use --backup-dir

to run a script on a schedule, use task scheduler.

1 Like

Thanks @asdffdsa

Must smile, the command was so simple, I searched for hours. So yes, I'm a newbie to rclone.

When I run the command on my win10 64bit I get this:

Fatal error: failed to mount FUSE fs: mount stopped before calling Init: mount failed: cgofuse: cannot find winfsp

I don't have mounted drive J: from before.

I can contact Jotta with other commands like

rclone lsd M:Work

so I can reach the backup on Jotta

You need to install WinFSP:

1 Like

a smile in the morning is always good.

you need to install this, rclone uses it for the mount

Thanks @asdffdsa @Animosity022

Another smile, but not a full grin, maybe tomorrow.

I also red the article @Animosity022 shared, good info regarding Admin/Not admin .

I run rclone not as admin like this:

C:\Users\Modesty\Desktop\rClone>rclone mount Jotta J:

2021/01/15 07:31:01 ERROR : Local file system at //?/C:/Users/Modesty/Desktop/rClone/Jotta: Statfs failed: failed to read disk usage: The system cannot find the path specified.
The service rclone has been started.

In explorer i see this:

Local ? C User Modesty Desk (J:)

No files visible

In Total Commander the drive is not visible at all.

Any new idea to share with me?

Are you just missing the : after Jotta, perhaps?

rclone mount Jotta: J:

Hi @albertony thanks for info.

I have tried. Conf file states only [Jotta]

C:\Users\Modesty\Desktop\rClone>rclone mount Jotta: J:

here is result:

2021/01/15 08:57:16 Failed to create file system for "Jotta:": didn't find section in config file

Conf file:

type = jottacloud
client_id = jottacli
client_secret =
tokenURL = htt p s://id. auth /realms/jottacloud/protocol/openid-connect/ token
token = {"access_token":"xxxx","expiry":"2021-xx-xxT08:25:09.x0x0x0x+04:00"}
configVersion = 1

Is it using the conf file you expect?

Check with command rclone config file

if you run that command with a username with admin privileges, you would have to run total commander that way.

and use this to specify the location of the the config file



You have correct, conf file correct place, but my spelling Jotta was wrong. Conf file updated and it works now.


I run rClone not in admin mode, Total commander (TC) dont see the drive J:
Explorer sees it.
I have tried rClone and TC in both admin and not admin. No change. TC dont kick in.

In TC I see:

Local ? C User Modesty Desk (J:)

To be able to do a quick compare NAS<->Jottacloud i was really hoping to se the drive in TC. Any of you that can give me another tip?

hard to know what is going on, as there is no debug log......

if you run both as admin, tc should use it.
perhaps restart tc?

as a test, open two command prompts, one with admin priv and one without.
run this with both
dir j:

these two options should solve the admin privelge problem.

  • run rclone as system user.
  • what i always do, mount to a folder, not a drive letter.
    rclone.exe mount remote: b:\mount\rclone\remote

I did try, did not help

Another strange issue
not the same file structure on Jotta as on NAS...

On NAS I see 4 shares/directories, Work,Private,Media,Photos + standard: admin + data

Under data I see the same 4 directories+ homes+Logs

On mounted J: i dont see any of them, and I see 8 different directories. I did expect to see more on Jotta due to not cleaning up last 10 years, bot not see the directories that i find in GUI is strange.

Is there a way to mount the 'data' directory? This directory I dont see under my mounted drive J: (jotta)


I see only files in GUI that is placed in Archive. I need to see files that are places on jottacloud in 'Backed up'. All "active" files are there.

Can this 'Backed up' directory be mounted?


rclone.exe mount "Jotta\Backed up": J:

for testing, i suggest using rclone ls.
once that display the correct information, then try rclone mount.

if you want to use rclone mount, the correct command would be
rclone.exe mount "Jotta:Backed up" J:

have you read this?
" if you want to access files uploaded by any of the official clients rclone provides the option to select other devices and mountpoints during config."

1 Like


thanks for your help @asdffdsa

From WIKI:
The official Jottacloud client registers a device for each computer you install it on, and then creates a mountpoint for each folder you select for Backup. The web interface uses a special device called Jotta for the Archive and Sync mountpoints. In most cases you'll want to use the Jotta/Archive device/mountpoint, however if you want to access files uploaded by any of the official clients rclone provides the option to select other devices and mountpoints during config.

each computer you install it on
I have 4 devises/computers/storage spaces in jottacloud, my NAS computer on Jottacloud is named VAIO.

In most cases you'll want to use the Jotta/Archive device/mountpoint
The Archive I reach with command

rclone mount Jotta: J:

The interesting part is that when a normal jotta backup is running it dont stores files in Archive. Files are stored in 'Backed up' under a Cat/Mount point VAIO (one computer)

The structure Archive + Backed Up is not directories, it is more like standalone shares, maybe what rClone calls a mountpoint?

What I see on Jottacloud when cliking "Backed up": (VAIO is the name of mye NAS backup)

When I click on VAIO i see this GUI: My NAS backup

official clients rclone provides the option to select other devices and mountpoints during config
I think this is the core info, what is the command to execute the "mountpoint " VAIO?

I have tried this without success:

rclone mount Jotta:VAIO v:
rclone mount Jotta:\VAIO v:
rclone mount Jotta:/VAIO v:

Thanks for help up front.

Correct, but it is the Jottacloud API itself, which rclone relies on, that uses the consepts of "Device" and "Mountpoint". Jottacloud groups separate filesystems in, first a Device and second a Mountpoint within that device. For backup functionality of the official Jottacloud client you will have a "Device" in Jottacloud matching each client you run the backup from. These are the ones grouped under the tab "Backed up" in your screenshot. For each of the backup devices, you will have a mountpoint for each directory/backup set configured backup for in the official client. In your screenshot you have a mountpoint "Modesty" in device "VAIO". There is a special built-in device called "Jotta" used for various built-in mountpoints not tied to a specific device, such as "Sync" and "Archive", which are on their own separate tab in your screenshot (the "Jotta" device itself is an internal detail not shown in user interfaces).

From rclone you need to configure a remote (which is an rclone term, by the way) to point to a single, specific Device and a single specific Mountpoint in Jottacloud. So if you want to access backup of a device called VAIO, you must configure an endpoint for that.

During the interactive config, you will be asked:

Edit advanced config? (y/n)

Selecting y here, and you will be asked to pick Device and Mountpoint, as seen in the example.

Some example configs:

To access "Backed up > VAIO > Modesty"

type = jottacloud
device = VAIO
mountpoint = Modesty

Which you can use like this:

rclone ls JottaVaioModesty:

To access the content you see in the "Synced" tab in the official client:

type = jottacloud
device = Jotta
mountpoint = Sync

Which you can use like this:

rclone ls JottaSync:


Thanks! It works. Love it. :grinning:

I had to delete first .conf file, then start the config procedure again, the advanced config question did not come.

As always, a solved issue born a new one :slight_smile:

As you noticed i have 4 mount points in jottacloud.

Now I have reached the most important mountpoint, but can rClone mount more of them at same time, like a script/batch file?

Drives on my win pc:


Rclone does not do that, but you just run multiple separate rclone commands.

Simplest solution: Create your own batch script mount.cmd containing something like this:

start "" rclone mount Vaio: J:
start "" rclone mount Work: K:
start "" rclone mount Photos: L:
start "" rclone mount Family: M:

Then there are more advanced solutions if you want to hide the rclone command prompt windows, automatically mount on Windows startup etc. There are several other forum posts around this, so try a search first if you want to explore this. For example:

Good morning

to manage to mount 4 drives I manipulated rclone.conf. I copied the config 3 times, changed names like this

type = jottacloud
client_id = jottacli
client_secret =
tokenURL =
token = {"access_token":" expiry":"2021-01-16T15:36:51.3801729+01:00"}
device = VAIO
mountpoint = Modesty
configVersion = 1

Above copied to make another mountpoint

type = jottacloud
client_id = jottacli
client_secret =
tokenURL =
token = {"access_token":" expiry":"2021-01-16T15:36:51.3801729+01:00"}
device = VAIO
mountpoint = Work
configVersion = 1

When I run

rclone mount JottaModesty: J:

I get an error, can it be something wrong with token when I copy / paste?

2021/01/17 08:48:36 Failed to create file system for "JottaModesty:": couldn't get customer info: Get "": couldn't fetch token - maybe it has expired? - refresh with "rclone config reconnect JottaModesty:": oauth2: cannot fetch token: 400 Bad Request
Response: {"error":"invalid_grant","error_description":"Stale token"}

Do I need to generate one token from for each section in .conf file?


I don't know, unfortunately, but sounds like it from the the error message. Perhaps executing rclone config reconnect JottaModesty: once for each of the remotes will fix it.

(I did edit my post above a bit: Originally used mountpoint "Archive" for the device "VAIO", which was wrong/confusing, since Archive is a built-in mountpoint on the Jotta device, and in the backup devices the top level "folders" are the mountpoints. You had that correct in the config shown in your latest post, though).

1 Like