How to modify Google Cloud Storage endpoint URI?

I'm working with Rclone to copy files/objects from an on-prem infrastructure to Google Cloud Storage.
My IT department ask me to use Private Service Connect to access Google APIs.
As a consequence, rather than using standard endpoint URI :
I need to use a specific one :
It seems that there is no specific option available in rclone config file or command line for GCS (while it seems to be possible for Azureblob or S3).
I would be very grateful if someone could help me on this topic.
rclone version : v1.53.1
os : RHEL 7.9

You are right, it isn't possible to set this at the moment.

Try this - I've added an endpoint config parameter or flag --gcs-endpoint

v1.60.0-beta.6413.e86c9ada6.fix-gcs-endpoint on branch fix-gcs-endpoint (uploaded in 15-30 mins)

That sounds good.
--gcs-endpoint option tested.
endpoint param in rclone.conf tested.

Methodology :

  • I test the command line with the correct --gcs-endpoint option which results in a successful copy.
  • I introduce a typo in the URI which results in an HTTP error.

Thank you Nick.

Thanks for testing.

I've merged this to master now which means it will be in the latest beta in 15-30 minutes and released in v1.60

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.