How to make remote copy not update the mod-time

What is the problem you are having with rclone?

How to make remote copy not update the mod-time.

I tried to use --no-update-modtime, --use-server-modtime, --checksum, --ignore-times parameters, but they couldn’t stop the update mod-time

What is your rclone version (output from rclone version)

rclone v1.53.3-DEV

  • os/arch: linux/amd64
  • go version: go1.15.9

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy --no-update-modtime onedrove:test/ onedrove:test1/ --log-level DEBUG --log-file=test.log --dump requests

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

2021/11/29 10:08:51 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2021/11/29 10:08:51 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2021/11/29 10:08:51 DEBUG : HTTP REQUEST (req 0xc0000cfd00)
2021/11/29 10:08:51 DEBUG : PATCH /v1.0/drives/xxxxxxxxxx/items/xxxxxxxxxx:/text.txt: HTTP/1.1
User-Agent: rclone/v1.53.3-DEV
Content-Length: 107
Authorization: XXXX
Content-Type: application/json
Accept-Encoding: gzip



And this part. If you make a new file, it has to get a modtime.

      --no-update-modtime                    Don't update destination mod-time if files identical
1 Like

Understood, I am make a new file

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.