How to force Content-type to text/plain on macos / S3-compatible?

I’m doing rclone copy Dockerfile my-s3:public/fooclient/ but it’s written with Content-Type: application/octet-stream. Of course that causes my browser to download the file instead of displaying the text.
https://my-s3.example.com/public/fooclient/Dockerfile

Files with .txt extension do get written as text/plain. I can’t find an rclone option to force the Content-type. Do I have to configure something in my macos High Sierra?

Thanks,
Jamshid Afshar

1 Like

Rclone uses the extension of the file to guess the content-type which normally works reasonably well, but not in this case…

There isn’t one at the moment.

This issue would solve the problem I think: https://github.com/ncw/rclone/issues/59

Though there might be a better way…

Rclone could read the first 512 bytes of the file to guess the content type - that might be a better way of doing it.

Or we could just have a --content-type flag which forced the content type of all uploads to be that passed in.

What do you think?