How to do I use remote

What is the problem you are having with rclone?

I want to move a 300BG+ file. Originally I was using Rclone mount but I got advice saying it's better to use a remote as it doesn't store cache on the computer

What is your rclone version (output from rclone version)

rclone v1.53.3
  • os/arch: windows/amd64
  • go version: go1.15.5

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 64 bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I saw this in the rclone mount guide but still not sure what to do

first set up your remote using rclone config. Check it works with rclone ls etc.

You can either run mount in foreground mode or background (daemon) mode. Mount runs in foreground mode by default, use the --daemon flag to specify background mode mode. Background mode is only supported on Linux and OSX, you can only run mount in foreground mode on Windows.

On Linux/macOS/FreeBSD Start the mount like this where /path/to/local/mount is an empty existing directory.

rclone mount remote:path/to/files /path/to/local/mount
Or on Windows like this where X: is an unused drive letter or use a path to non-existent directory.

rclone mount remote:path/to/files X:
rclone mount remote:path/to/files C:\path\to\nonexistent\directory

So for this part

rclone mount remote:path/to/files X:
rclone mount remote:path/to/files C:\path\to\nonexistent\directory

If I when I mount it using the letter or a nonexistent directory, does it get mounted as similar to using rclone mount(without the remote). My current command it like so

rclone mount GoogleDrive: U: --vfs-cache-max-size 10G --cache-dir "D:\Tools For Games\Mount Google Drives\Rclone\Cache Folder" --vfs-cache-mode full

When using rclone mount remote should I still use

--vfs-cache-max-size 10G --cache-dir "D:\Tools For Games\Mount Google Drives\Rclone\Cache Folder" --vfs-cache-mode full

or does it use a different command?

in both cases, rclone is using a remote.

so the command might look like
rclone copy C:\path\to\local\directory\300GB.file remote:

Do i still need to use this

--vfs-cache-max-size 10G --cache-dir "D:\Tools For Games\Mount Google Drives\Rclone\Cache Folder" --vfs-cache-mode full

using a remote doesn't store anything as cache right?

vfs only applies to rclone mount and even then, it is optional
many rcloners do not use vfs cache with rclone mount

the command you want is
it uploads direct to remote.
it does not use vfs cache or any kind of cache.

Hi can you help me. I'm using this command now and nothing happens

rclone copy "Z: \Movies\MasterClass BBQ\Test" "GoogleDrive: \Test"

Am I supposed to replace "GoogleDrive" with the assigned letter instead?


  • can you post the output of rclone listremotes
  • the Z: - is that a real drive letter or a rclone mount?

Z: is the letter assigned to my WD NAS Network Drive. for the destination command, does it matter if I use the letter or the name?

can you post the output of rclone listremotes

when you post the command, use image

D:\Tools For Games\Mount Google Drives\Rclone>rclone listremotes

D:\Tools For Games\Mount Google Drives\Rclone>

It seems to be working now however thank you

when testing use --dry-run and --progress

Are these normal upload speeds or should I be worried about some rclone setting I have to change?

The link is my internet speed and the cmd prompt window

not sure what you mean about normal?

is it a "good enough" upload speed when compared to the results? I'm worried I should change a setting that might be throttling my uploads speeds. I already change the --drive-chunk-size to 256M, made my own client id also
. Is there anything else?

sorry, cannot give you an answer, too many variables.
gdrive has all kinds of limits, bans, 2 transactions per second and on and on.
and it depends on the mix of files, number of files, size of files and on and on.

when i first started using rclone with wasabi and found the best settings.
i did a bunch of tests, tweaking transfers, checkers, chunk size.
i suggest that you do the same.

as for internet speeds, there is no normal

i see, just out of curiosity what is your upload speeds using rclone copy?

I'm using rclone copy on a folder with 11 files in the folder. In the image located in the link it shows only 4 files under the "transferring". Does that mean that only 4 files are transferring at a time and the other 7 files will only begin transferring after the first 4 are done? Is there anyway to increase it to 11 files under the "transferring"

take a read of this -

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.