How many rclone mount sessions should my server be running?

Hi guys.

I seems to be having major problems streaming from my Plex. Its almost impossible to stream anything from acd. I checket my active sessions via htop in ubuntu and I have so many active rclone mount sessions?

Also I can see via logs that the server is transferring aprox 100GB ( which I haven’t started, and im the only one with access to the server )

At this time - im sleeping :slight_smile: , so I really wonder what is going on?

I hope that someone can help me out .



Looks like you have some runaway mount script or something. You shouldn’t have more than 1 process for the mount.

Well followed Ajki :slight_smile:

Something is executing that script many, many times.

Do you have it in cron, systemd startup or something along those lines?

I’m running pretty much the same script with “sh”, manually (no cronjob) - looks like this:

What’s the full output of:

ps -ef | grep rclone

I’m curious to see how many you got running and we can probably figure out the parent process that kicked it off.

You could also try killing them all out and starting fresh by doing something like:
pkill rclone

That will kill them all though so make sure no one is using it :slight_smile:

Running the ps/grep command:

Can’t close off the rclone right now, people are using my Plex server :slight_smile:

Oh I’m stupid. Sorry.

Your first screenshot is from htop. You have ‘threads’ on in the display. So you are seeing all the ‘threads’ running for a single process. You can change that in the setup of htop by hitting F2 and looking at the display options:

That’s totally normal for a lot of threads to run for a single thread.

Results after applying the “Hide userland process threads”:

(and of course applying the F4 filters of “rclone mount” :slight_smile: )

So that’s the difference of running:

ps -ef | grep rclone

ps -efT | grep rclone

The latter gives you all the threads.

Here you go :slight_smile:

1 Like