How does one set a password for the GUI?

What is the problem you are having with rclone?

I can't set up a password for the GUI (set it up without one), and the documentation is useless in that regard.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 x64 20H2

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone rcd --rc-web-gui

The rclone config contents with secrets removed.

there's nothing in the config file

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

this is an example, change the username and pass as needed.
rclone rcd --rc-web-gui --rc-user x --rc-pass x -vv

also, this work would work

In fact, the whole documentation is confusing. The first thing it tells me is to try the start the configuration using the command rconf --config when the --config is not even a valid option at all.

Also, the documentation tells that if I create an rconf.conf file in the executable folder, it will use it. Here it seems to just ignore that file altogether.

Btw, there's no "getting started" in the documentation and I have no idea what I should put in the config file.

Then, there's the webUI. It's easy to use, but once I get out of it, I'm asked for a password I never set, nor did I have an option to set in the first place.

I looked the internet up, it seems you should run rclone passing the --no-auth flag to it.

When I try it, rclone seems to become unresponsive, cause when I try to access it from my browser it just hangs forever.

I need to use rclone, but gosh, what a cumbersome thing to set up, even reading the documentation I have no idea how to get it up and running.

But what if I don't want to use a password at all?

I'm using this on my personal machine, it has a password and an encrypted disk, I wanted to have no password.

i think you have to login using username and password

might try this

That seems to be the case. When I launch it using the --rc-no-auth option it becomes unresponsive.

My god, isn't there any easy way to set this up?

run it from a batch file.

this is an example, change the username and pass as needed.

rclone rcd --rc-web-gui --rc-user x --rc-pass x -vv

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.