How do I set a setting like client_id to blank using rclone config?

How do I set a setting like client_id to blank using rclone config?


rclone config

Let's say I have a remote, it's got settings, with values, I want o set one of those values to blank. But if I just hit enter on a blank line while editing a remote, instead of setting it to blank, it simply doesn't edit it. This is great 99.9999% of the time, but if I wanted to set something to blank via rclone config is there a way? Or do I have to delete the remote and remake it?

edit: Why do I care at all? getting an access token via noVNC on a remote server without the ability to copy/paste is a nightmare :slight_smile:

I do not think it is possible.

Connect to remote over ssh then you can copy/paste without issues.

It would be cool if there was something magical you could type to blank a setting, like "blank this setting". This remote server isn't set up for ssh, it doesn't have a domain, and it doesn't have to do anything ever except run one or two rclone commands, I can use an automatic key program to input copy/pasted data, so it's only the authorize string I need to manually type, it's pretty tough though as it's quite long and I always have at least one hidden typo.

Now in hindsight setting ssh would've been correct, but in foresight I didn't except dropbox to burn out in two weeks :slight_smile:

I see indeed it is a problem:) But not sure why copy/paste does not work. Maybe it is noVNC limitation. Normally you have to configure autocutsel on your remote machine and it works.

Googling it implies noVNC has a limitation that doesn't allow copy/paste, likely due to not allowing things like ctrl, so it would be hard to do anything like copy/paste. autocutsel might solve the problem, but typing 30 random letters and numbers correctly one more time is probably easier for me than learning how to set up autocutsel :slight_smile:

1 Like

I'd just use vi on said machine to edit rclone.conf and blank the lines there.
Fast and easy.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.