How Do I Mount MEGA as a drive with Rclone

How's it going

I'm not a tech noob but Rclone... Damn I must be slow with this... I've made MEGA profiles on this one after the other different ways different settings different accounts different EVERYTHING... But it's literally never let me mount my MEGA drive... I'm on Ubuntu 18.04, anyone know the exact step by step guide too set up MEGA and mount, literally the "your a idiot guide too the Galaxy of Rclone"

Thanks in advance :blush:

Refer these two links:

https://rclone.org/mega/

https://rclone.org/commands/rclone_mount/

Ok I made the whole thing again and then got blasted at rclone ls command... Got me some of this...

/$ rclone ls mega:

2020/01/21 18:53:12 NOTICE: Config file "/home/thecryingwontstop999/.config/rclone/rclone.conf" not found - using defaults

2020/01/21 18:53:12 Failed to create file system for "mega:": didn't find section in config file

how did you install rclone? as per https://rclone.org/install/

where is your config file located?

you need to make sure file permissions are set correctly, that the user rclone is running as, has permission to access the rclone.conf file.

Ok I reinstalled the whole thing, and set up the drive again, rclone lsd MEGA: works and populates with all my folders, so I made a folder for the specific purpose of mounting and ran "rclone mount MEGA:Server /home/thecryingwontstop999/Server" which mounts it but doesn't list the folders with anything, I made a folder in my MEGA "Test Folder" then unmounted and re-mounted, still not showing up my test folder, and when I tried creating a folder within the mount and permission was denied...

My specific purpose for mounting MEGA is to use with Plex, streaming media etc.. etc.., what should I run too effectively have the drive run multiple streams all through MEGA

Thanks in advance :metal:

rclone mount MEGA:Server /home/thecryingwontstop999/Server

Implies there is a folder named Server in your MEGA directory. If there is no such folder, the directory that is mounted to will be empty.

There is a folder named "Server" in my MEGA, if my MEGA drive was written as a directory it'd be "MEGA:Server/ThisIsATest" so I go and mount the Server folder as seen above yet the "ThisIsATest" folder isn't showing up in the directory on the computer, but it's in the MEGA drive

Can you add the debug logs from rclone then?