How can we limit the number of file using rclone copy

We are pulling files from vendor's s3 bucket using rclone copy. There are about 5k files I am interested in only getting 100 files. Doesn't matter which 100 files it picks.
I am using this syntax
rclone copy --ignore-checksum --no-traverse --verbose .........................
I tried using
rclone copy --ignore-checksum --transfers=100 --no-traverse --verbose ........
it copied a bunch of 100 at a time but I am only interested 100 files and stop the copy
What parameter can I add to get the required result?

hello and welcome to the forum,

one way

  1. rclone ls source: > list.lst
  2. take the top 100 lines from list.lst and save it as short.lst
  3. rclone copy source: dest: --files-from=short.lst

Are there any options/parameters that I can add to rclone which would limit to 100 files

not that i know of,

this would work
rclone lsf ./source --absolute --files-only | head -100 | rclone copy ./source ./dest --files-from=-

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.