How can i read & write a mount with b2?


#1

Hi, How can i read & write a mount with b2 ?

I use this “sudo rclone mount --allow-other b2:/test” create a mount, only can read, can’t write anythings.


#2

Don’t use sudo. Just mount as your user and it should all work fine.


#3

Thanks for response !
I already remove sudo, but the mount still read-only, and output following message in console. “B2 bucket test: poll-interval is not supported by this remote”.


#4

Check to see if /etc/fuse.conf has

# Allow non-root users to specify the allow_other or allow_root mount options.
user_allow_other

In it

You can ignore that message


#5

Thanks ncw,
/etc/fuse.conf. I haven’t got such a file, is could be created manually?


#6

Sure, just stick something like this in it

# /etc/fuse.conf - Configuration file for Filesystem in Userspace (FUSE)

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#mount_max = 1000

# Allow non-root users to specify the allow_other or allow_root mount options.
user_allow_other

I’m not 100% sure that will fix the prob, but worth a try!