Help with url for WebDav


Just have a quick question about setting up a remote as a WebDav that is served from my synology drive. If I'm using Nautilus on Ubuntu then I can connect to it with:




and both of those work great. However when I try to use either of these with the rclone config steps, I get this as the output once I try to acces it

Configuration complete.
- type: webdav
- url: dav://
- vendor: other
- user: blah
- pass: *** ENCRYPTED ***
Keep this "juniper-nas" remote?
y) Yes this is OK (default)
e) Edit this remote
d) Delete this remote

Current remotes:

Name                 Type
====                 ====
dropbox-rte          dropbox
juniper-nas          webdav

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q> q
r@astro:~$ rclone lsd juniper-nas:
2022/08/15 02:50:46 ERROR : : error listing: couldn't list files: Propfind "dav://": unsupported protocol scheme "dav"
2022/08/15 02:50:46 Failed to lsd with 2 errors: last error was: couldn't list files: Propfind "dav://": unsupported protocol scheme "dav"

I get the same output if I try with url = davs:// If I use just then I get a slightly different error:

r@astro:~$ rclone lsd juniper-nas:
2022/08/15 02:59:28 Failed to create file system for "juniper-nas:": parse "": first path segment in URL cannot contain colon

So it appears that I need some protocol prefix, but dav: and davs: are not supported, like in nautilus? I'm a little clueless what the url should be in this case, as it is still being served localy (on my synology router running SRM)

Thanks for any help. Here is my rclone info:

r@astro:~$ rclone version
rclone v1.59.0
- os/version: ubuntu 20.04 (64 bit)
- os/kernel: 5.10.65-tegra (aarch64)
- os/type: linux
- os/arch: arm64
- go/version: go1.18.3
- go/linking: static
- go/tags: none

What's your rclone.conf look like?

The URL should be something like:

URL of http host to connect to
Choose a number from below, or type in your own value
 1 / Connect to
   \ ""

Thanks for the reply,

I don't have a public domain for it - as I tried to show above the WebDAV server is hosted from my synology router and accessible via dav:// or davs:// (second one is HTTPS and would prefer that if possible).

I basically followed the instructions here to setup WebDAV on the Synology router.

dav:// is a shorcut for your Nautilus application and you'd need to use HTTP or HTTPS like in the example.

If you share your rclone.conf, I'm happy to give you exactly what it should look like.

Apologies for the delay on this, been discussing with Synology about options. And finally figured out that I just needed an http:// in the protocol prefix! :man_facepalming:

The following config worked for me connecting to Synology SRM's WebDAV server, serving up the usb drive connected to the router:

type = webdav
url =
vendor = other
user = xxx
pass = XXX

Where is the ip address of the router. Glad to have it working! All making much more sense now.

Thanks again,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.