Help with genautocomplete

I'm trying to get genautocomplete set up because I am finding rclone hard to navigate without it.
when I run the "sudo rclone genautocomplete zsh" command, I get "open /usr/share/zsh/vendor-completions/_rclone: no such file or directory". When I try to create that folder in macos the operation is not permitted. Has anyone had any luck getting genautocomplete setup on MacOS and zsh?

I'm using ohmyzsh
rclone v1.51.0
zsh 5.7.1
MacOS 10.15.3

1 Like

You might find this thread helpful

Hi, I've read through that thread a few times now and I don't believe anything was resolved.
I cannot get remote completion working. I've tried installing the genautocomplete in my /usr/local/share/zsh/site-functions and also .oh-my-zsh/plugins/ and installing as a plugin. I'm able to complete rclone commands, just not remote file paths. Has anyone had success getting this working on MacOS with ohmyzsh?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.