Headless Authentication to OneDrive for Business?

Hi Everyone,

I'm trying to config rclone on a computer without a web browser to sync with OneDrive for Business. When I run the rclone authorize onedrive command, it only lets me authenticate with personal credentials, not business credentials, so I'm unable to use OneDrive for Business.

Am I missing something obvious here? I do not believe login(dot)live(dot)com actually allows business accounts, and that is where rclone is going to have me authenticate, so I am not sure how to proceed.

hello and welcome to the forum,

the software is named rclone, not rsync

for the business account, you login with a live.com address, not a custom domain name?

can you share the output and the errors?

Well, that is pretty embarrassing that I typed the wrong software name. :sweat_smile: Sorry!

When I run rclone authorize onedrive, it tells me to go to a specific page. That page (in my case) is "". When I go to that page, it is a redirect to login(dot)live(dot)com as you can see here:

However, that subdomain from Microsoft never allows business logins (as far as I know?). You have to use a personal account which does not work for OneDrive for Business. The proper URL for business authentication on the Microsoft end should be login(dot)microsoftonline(dot)com. That URL will then redirect to login(dot)live(dot)com if you enter a personal account, but it will stay on login(dot)microsoftonline(dot)com if you enter a business account.

So basically, I can't authenticate with a business account on the page that rclone is sending me to. Sorry for all the text links. I can't post "real" links because I'm new.

You need to update rclone as you are using an old version.

The template for support asks for the version for that reason as it helps you and me save time.

My apologies. I thought I had the latest, but I obviously do not. I'll give that a try.

Of course, you are correct. Thanks for the help.

1 Like

The only reason I recall this one as I spent some time with someone using a different machine with an old version and I remembered the live.com was an older version of rclone :slight_smile:

Happy you got it working!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.