Having an issue copying local files

I am trying to copy files from Local Folder to a UNC path, but none of the global flag are working.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows server 2012 64 bit

Which cloud storage system are you using? (eg Google Drive)

NONE Using Local system.

This command works great
copy D:\DataSources\Photos\Output\Client1\ \\\d$\Client1\Photo\
But if I try to do anything with global flag it will break
copy --auto-confirm D:\DataSources\Photos\Output\Client1\ \\\d$\Client1\Photo\
The system cannot find the file specified.

Any help would be appreciated.

hello and welcome to the forum,

that is an old version of rclone, best to update and test again.

when you posted there was a template of questions.
not sure why you left out the exact commands and the debug logs?

Exact Command with output is below

copy --auto-confirm D:\DataSources\Photos\Output\OK-Ellis\ \\\d$\OK\Ellis\Photo\
The system cannot find the file specified.

Update to version 1.55.1

still having the same issue.

The system cannot find the file specified.

Here you go

is there a specific reason to use --auto-confirm?

please, add -vv to the command and post the entire output.
it will look like

rclone.exe lsd aws_vserver03_veeam_br_en07: -vv 
2021/06/02 12:25:21 DEBUG : Using config file from "C:\\data\\rclone\\scripts\\aws.conf"
2021/06/02 12:25:21 DEBUG : rclone: Version "v1.55.1" starting with parameters ["c:\\data\\rclone\\scripts\\rclone.exe" "lsd" "aws_vserver03_veeam_br_en07:" "-vv"]
2021/06/02 12:25:21 DEBUG : Creating backend with remote "aws_vserver03_veeam_br_en07:"
2021/06/02 12:25:21 DEBUG : Creating backend with remote "aws_vserver03_veeam_br_en07_remote:vserver03.veeam.br.en07"
2021/06/02 12:25:21 DEBUG : fs cache: renaming cache item "aws_vserver03_veeam_br_en07:" to be canonical "aws_vserver03_veeam_br_en07_remote:vserver03.veeam.br.en07"
           0 2021-06-02 12:25:21        -1 en07
2021/06/02 12:25:21 DEBUG : 4 go routines active

Sorry when running this
copy D:\DataSources\Photos\Output\OK-Ellis\ \\\d$\OK\Ellis\Photo\ -vv
The only output I get is
copy D:\DataSources\Photos\Output\OK-Ellis\ \\\d$\OK\Ellis\Photo\ -vv The syntax of the command is incorrect.

The reason for the autoconfirm is I am running the in a ETL process, if the image already exists on the remote side I would like it to overwrite, as the process is unattended.

those are not valid commands.
you would need to add rclone or rclone.exe to the start of the command

Im so sorry for bothering you. one of those bone head moments. thanks its working now.

sure, no problem.
we all make that mistake once, never twice :wink:

not sure what that is, but i never read of anybody using --auto-confirm with rclone copy.
i am curious why you must use that flag?

I guess maybe I don't need to use that. I got myself all kinda tangled up, accidentally running DOS Copy. We are embedding this into an SQL Server Integration Services Package, so when the Exe is called in the package we don't have to specify the RCLONE at the beginning of the call because the .exe is already targeted. Hence the bad command line code.

ETL is Extract, Transform, and Load. DBA speak I guess lol

of course, running DOS Copy is an accident. :wink:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.