Gsuite: couldn't list directory: googleapi: Error 404: File not found: ., notFound

Hello everyone!

I'm trying to set up rclone for the first time. I've subscribed to the Gsuite business plan yesterday. For that I've followed this guide https://rclone.org/drive/ and everything seem to work well (my client_id and client_secret has been created with a different Google account, not the one I use with Gsuite).

Now, when I try to copy my first test file into gdrive:

rclone copy --verbose test.txt maxsuite:/

I get this:

2019/12/14 22:36:57 ERROR : Attempt 3/3 failed with 1 errors and: couldn't list directory: googleapi: Error 404: File not found: ., notFound

I'm using this build rclone-v1.50.2-windows-amd64
but I've also tried:
rclone-v1.50.2-windows-386rclone-v1.50.2-windows-386
rclone-beta-latest-windows-amd64
with same error.

My config:

[maxsuite]
type = drive
client_id = .apps.googleusercontent.com
client_secret = ************************
scope = drive
root_folder_id = backup
token = {"access_token":"
","token_type":"Bearer","refresh_token":"1//03********","expiry":"2019-12-14T23:20:11.750642+01:00"}

I would be very grateful if someone could help me out here, I'm total noob.
Thanks!

This command inherently doesn't make sense from rclone's perspective.
A copy command needs a source and a destination location.
and what is test.txt in this context supposed to be? What does it contain?

Please tell me what you are trying to do do and I will suggest and appropriate command- as it seems like you may be stuck on some basic syntax here...

EDIT:
When I re-read your post I imagine you might be trying to copy the file test.txt to the Gdrive remote named maxsuite:

If so the command might looks something like this (on Linux)
rclone copy /home/stigma/test.txt maxsuite:/ --verbose
(on Windows):
rclone copy C:\test.txt maxsuite:\ --verbose

If you are new to rclone you may want to set up a mount (ie. simulating that the Gdrive is a normal harddrive on the system). This is usually much more intuitive for a beginner since you can just drag&drop files in the OS interface like you may be used to. Let me know if you are interested in further details about how to do this. It's well worth to know native commands as they have their benefits over a mount, but a mount is usually a good place to "get started" with rclone.

EDIT2: This is almost certainly not a bug, but rather a simple user error/misunderstanding. Bug classifications are best used when you are well familiar with the system and you are fairly sure that rclone is not behaving in the way that was intended.

I think this is probably wrong. Try deleting that line from your config.

root_folder_id is for drive IDs which normally look like 32 random alphabetic characters.