Google Work Space + Plex +RClone Mount settings

What is the problem you are having with rclone?
I'm reaching the google drive API download limit.

I'm on
rclone v1.57.0

  • os/version: darwin 10.15.7 (64 bit)
  • os/kernel: 19.6.0 (x86_64)
  • os/type: darwin
  • os/arch: amd64
  • go/version: go1.17.2
  • go/linking: dynamic
  • go/tags: cmount

I'm using google workspace.

I recently changed my commands to match what's below.
I have not been able to test it yet but wanted to see if anyone had any advice on what to do.

--log-file ~/Documents/_FILES_HANDLING/rclone.log \
--vfs-read-chunk-size 2G \
--vfs-cache-mode full \
--poll-interval 15s \
--buffer-size 12G \
--allow-other \
--rc \
--dir-cache-time 96h \
--vfs-cache-mode writes \
--cache-dir  ~/Movies/cache \
--rc-addr REDACTED_IP:5572 \
--rc-pass REDACTED \
--rc-user REDACTED \

hello and welcome to the forum,

many @VBB has some suggestions....

There can only be ONE!

I don't use cache mode, so I can't really be of help with that, but I would definitely remove or at least reduce --buffer-size 12G significantly.

Also, look at some of the more recent streaming-related threads here. There's a ton of info! Just search for Plex.

--vfs-cache-mode full
--vfs-cache-mode writes
cannot use both, have to choose ONE
using plex, i suggest --vfs-cache-mode full

and the redacted config file is missing, did you create your own client id?

and the exact error from rclone log would be helpful?

and this is a good guide for gdrive settings to be used with plex.

and this is good plex advice to prevent api and download limit issues.

type = cache
remote = gdrive-media:/media
plex_url =
plex_username = ...
plex_password = ...
info_age = 1d
plex_insecure = gcrypt
db_path = crypt
chunk_path = gcache:/crypt
chunk_clean_interval = 2s
read_retries = 1

type = drive
client_id =
client_secret =
scope = drive
root_folder_id =
token =
team_drive =

type = crypt
remote = gdrivemedia:/
password = ...
password2 = ...

when you posted,
did not post the full rclone mount command,
did not post a debug log,
so no idea what remote you are using???

i see that you sent me a private message,
i cannot take money and will not remote into your comptuer,
but i do accept guinness extra stout :beer:

based on that config file, i have an idea about might be wrong with your setup.
so please post the full rclone mount command you are using.

I believe this is what you're asking for.

rclone mount gdrivemediacrypt: /Users/server/Desktop/gdrivemediacrypt/
--log-file ~/Documents/_FILES_HANDLING/rclone.log
--vfs-read-chunk-size 2G
--vfs-cache-mode full
--poll-interval 10s
--buffer-size 12G
--dir-cache-time 96h
--cache-dir ~/Movies/cache
--rc-addr REDACTED_IP:5572
--rc-pass REDACTED
--rc-user REDACTED

i really hope you are not using the gcache remote, where did you get that from?

try a simpler command and play a media file.
for what it is worth, i do not use any vfs flags for my rclone mount

rclone mount gdrivemediacrypt: /Users/server/Desktop/gdrivemediacrypt/
--poll-interval 10s
--cache-dir ~/Movies/cache
 -vv --log-file ~/Documents/_FILES_HANDLING/rclone.log 

I'm not using it, it was part of a tutorial I followed.

I'll give your commands a try now.

I just tried it and got the following error from Plex:

An unknown error occurred (4294967283)

Error code: 4294967283

i do not use plex.

not using plex, make sure the you can access the files in

I just tried playing one of the files in that directory and VLC returned an error..
I checked the permissions for that directory and everything looked fine.. just incase I re-set the read/write permissions to it..tried the same video file again and it worked...

Well, that was short lived... Same issue again nothing will playback and some non-playback issue when I try one of the files directly from the remote.
rClone didn't create a log in the directory we specified...

In get the following Error in terminal:
ERROR : IO error: open file failed: googleapi: Error 403: The download quota for this file has been exceeded., downloadQuotaExceeded

is that file a shared file or played multiple times?

Yes, but I'm receiving the message for any file on the drive.

i do not use gdrive

from what i have read in the forum,
that is somewhat common with shared drives.

if you try to download the file using the gdrive website, what happens?