Google Token requires "developer" access

What is the problem you are having with rclone?

I suddenly realized that my Google Drive and Google Photos clones were nor running.

Run the command 'rclone version' and share the full output of the command.

  • rclone v1.62.2
  • os/version: Microsoft Windows 10 Pro 22H2 (64 bit)
  • os/kernel: 10.0.19045.2965 Build 19045.2965.2965 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone authorize "drive" "ey -- REDEACTED -- n0"

The rclone config contents with secrets removed.

type = onedrive
token = {"access_token":"EwCIA - REDACTED - HiKQAg==","token_type":"Bearer","refresh_token":"M.C107_ - REDACTED - pbjA$$","expiry":"2023-05-15T17:23:09.648320376+01:00"}
drive_id = 23a396028c0b7068
drive_type = personal
link_scope = organization
link_type = edit

type = google photos
client_id = 5751 - REDACTED -
client_secret = GOCSPX- REDACTED - T8GNmR
token = {"access_token":"ya29- REDATCED - WZE","expiry":"2023-01-30T21:50:28.353894092Z"}

type = drive
client_id = 1614 - REDACTED -
client_secret = GO - REDACTED - cR
scope = drive
token = {"access_token":"ya29 - REDACTED - -8EGYQ","expiry":"2023-01-30T22:14:16.543901744Z"}
team_drive = 

A log from the command with the -vv flag

rclone sync GoogleDrive: /mnt/1TB_HDD/GoogleDrive -vv
2023/05/15 20:35:12 DEBUG : rclone: Version "v1.62.2" starting with parameters ["rclone" "sync" "GoogleDrive:" "/mnt/1TB_HDD/GoogleDrive" "-vv"]
2023/05/15 20:35:12 DEBUG : Creating backend with remote "GoogleDrive:"
2023/05/15 20:35:12 DEBUG : Using config file from "/home/pi/.config/rclone/rclone.conf"
2023/05/15 20:35:12 DEBUG : GoogleDrive: Loaded invalid token from config file - ignoring
2023/05/15 20:35:12 DEBUG : GoogleDrive: got fatal oauth error: oauth2: cannot fetch token: 400 Bad Request
Response: {
  "error": "invalid_grant",
  "error_description": "Bad Request"
2023/05/15 20:35:12 Failed to create file system for "GoogleDrive:": couldn't find root directory ID: Get "": couldn't fetch token: invalid_grant: maybe token expired? - try refreshing with "rclone config reconnect GoogleDrive:"

I then ran the suggested command and received the following:

 rclone config reconnect GoogleDrive:
Already have a token - refresh?
y) Yes (default)
n) No
y/n> y

Use web browser to automatically authenticate rclone with remote?
 * Say Y if the machine running rclone has a web browser you can use
 * Say N if running rclone on a (remote) machine without web browser access
If not sure try Y. If Y failed, try N.

y) Yes (default)
n) No
y/n> n

Option config_token.
For this to work, you will need rclone available on a machine that has
a web browser available.
For more help and alternate methods see:
Execute the following on the machine with the web browser (same rclone
version recommended):
        rclone authorize "drive" "eyJjbGllbnRfaWQiOiIxNjE0MjkwODc1OTUtcmpocDloM3I5dWk2dnFrZ3JiMGMzaHZkYWc1bzVvN3EuYXBwcy5nb29nbGV1c2VyY29udGVudC5jb20iLCJjbGllbnRfc2VjcmV0IjoiR09DU1BYLWJaczV1LTVvSUlDd3pXU0hUcXZfYkZ6RWZVY1IiLCJzY29wZSI6ImRyaXZlIn0"
Then paste the result.
Enter a value.

I then copied the rclone authorize command to my Windows laptop, and the result is the screenshot that I posted at the top.

That's all in your Google Admin console as you've configured your own client ID and secret in there.

Did you change / do something with the oAuth consent screen?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.