Google team drive list trash folder

i would see any file/folder in a trash of team drive
i don't want expugne trash, but only list file/folder...

so i create a remote

type = drive
scope = drive
token = .....................
team_drive = ...............
root_folder_id = 

type = drive
scope = drive
token = .....................
team_drive = ...............
root_folder_id = 
trashed_only = true

but when i run
rclone.exe lsd team123:
i see 2 folder (ok) but when i run
rclone.exe lsd team123_trash:
i see same 2 folder, instead in web interface i see more folder

i try also
rclone.exe lsd team123: --drive-trashed-only
but same result...

i use rclone 1.56.1 (updated today) on windows 10 pro .

thank you


can you post the debug log for the commands?

thank you for reply.

i see that inside 2 folders the content is different
in fact in google drive one is empty, and in _trash i see deleted files (i think)

so now i check this , berfore purge all trash .

because on google drive is more slow to load page...
my idea is clean something , then check and purge all onweb interface...

thank you

i did a quick test and i was able to reproduce the issue.

for some reason, rclone lsd remote: --drive-trashed-only does not list the directories in the trash.
instead, that command lists the directories not in the trash.

tho rclone ls --drive-trashed-only seems to work.

yes, i try now and is correct....

now i check all files (not tree / folders)...

thank you

i have more folder and files, from webinterface i can't delete...

also from rclone i can't delete files folder from trash...

so if i run
rclone ls remote: --drive-trashed-only
i list every file, can i pass command and delete it one by one.
i think similar
rclone ls remote: --drive-trashed-only | rm -rf

thank you

that will not work, as rm is a command to be run on local file system.

if you want to delete all files from trash
as this command will permanently delete all files in trash, test first with --dry-run

ok, thank you.

i found problem...

rclone say
Cannot delete folder: Server says: Forbidden (status code 403): The user does not have sufficient permissions for this file.

it's strange... now i check if can empty trash from app google drive (for windows) ...
but is not related to rclone, i have this poblem with another software also...

thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.