Google photos upoload - duplicate albums

Basic query....

I have a linux box with a folder structure storing my photos. Each directory is full of images, and there are no sub-folders.

I want to upload these to google photos so that each directory becomes an album full of the photos from that directory.

rclone copy <local_path> "google photos":album

works....but it creates a new album for every file. So if the original folder "Bob" contans 120 images, the above command gives me 10 photos in Google Photos, each in separate album, and each album with the name "Bob"

What am I doing wrong here...

That sounds strange! Can you make a small example and post the output of it with the -vv flag?


No problem:

Trying to upload a folder called "Budapest 2012" from my linux box, an excerpt from the logs shows:

2020/01/24 23:50:19 DEBUG : Google Photos path "album": >Put:
2020/01/24 23:50:19 DEBUG : Budapest 2012/P1030550.jpg: Size:
2020/01/24 23:50:19 DEBUG : Budapest 2012/P1030550.jpg: >Size:
2020/01/24 23:50:19 INFO : Budapest 2012/P1030550.jpg: Copied (new)
2020/01/24 23:50:19 DEBUG : Google Photos path "album": Put: src=Budapest 2012/P1030554.jpg
2020/01/24 23:50:19 DEBUG : Budapest 2012/P1030554.jpg: Update: src=Budapest 2012/P1030554.jpg

The result seems to be the files are uploaded, but each into albums of the same name...

I tried a little test myself

rclone copy 200102 -vv TestGooglePhotos:album/200102

That folder contained 6 photos.

They uploaded into one album called "200102" verified with the google photos albums view

Can you show me the exact command you are using please?

Ah - OK that may be the problem:

I was using:

rclone -vv copy /mnt/disk2/flickr/ "google photos":album

The "flickr" directory contains multiple folders, named "albumX", "albumY" etc

When I run this, I get an album created for every single photo that is uploaded, even if they are inside the same folder - hence the duplicates

Perhaps instead of the above, I need a bit of bash script to loop through every folder and call:

rclone -vv copy /mnt/disk2/flickr/albumX "google photos":album/albumX

This should work fine. It did in my tests :confused:

Can you post (or email me - put a link to this page in the email) the full log generated with -vv --log-file gphotos.log please, a log where you upload some files and the multiple album problem happens?


Thanks - I'll try that. Right now I am trying to delete the many thousands of albums so I can start again in a more controlled fashion.

Google photos doesn't seem to allow bulk operations for things like deleting it is a slow process, though this tool:

Has helped :slight_smile:

That is a really useful tool - thanks! I'm now using it to clear out my test account which has 1000s of albums from the continuous integration tester!

I'm having the same issue, twice now, and seems intermittent.

I have a root folder with hundreds of nested sub folders containing thousands of videos I want to upload to Google Photos in one HomeVids album

I don't want an album per subfolder so I have a program that iterates through the all the subfolders - those that are leaves of the tree structure - and invokes rclone each time to copy all the videos in the subfolder to HomeVids

rclone copy sourcefolder remote:album/HomeVids

This worked well for a while and then it suddenly started creating a new HomeVids albums for each video.
I noticed this early enough - around 50 Albums - so was able to interrupt the program, clean up and start again. I kept the original HomeVids album with 149 videos.

When I listed all the albums I see them all with the same name HomeVids followed by some UUID like this:

rclone lsd remote:album
... 149 HomeVids {Azase ...... OPJ73sn} <== This is my intended target
... 1 HomeVids {Azkdsjlk.......Okdsnmj}
... 1 HomeVids {AkQWEk......JIOUJDKJLK}
(truncated for brevity)

So I tried again using the name and UUID as follows to ensure all new vids were uploaded into the one HomeVids album I want - the one with 149 items.

rclone copy sourcefolder remote:album/"HomeVids {Azase ...... OPJ73sn}"

This worked well... all videos were uploaded and added to album HomeVids, until it didn't anymore.
This time it has created a second HomeVids album where the actual name in text is :
HomeVids {Azase ...... OPJ73sn}
and all videos are currently being added to this second one.
I have around 700 in the first one and currently 200 in the second.

I do not have the logs as the process is still running and I don't want to interrupt again at the moment, But if I have to start again I will use the -vv flag, hoping rclone appends when run multiple times.

Note. the album I am trying to group everything under is shared.

Could it be a session/timing thing...that a new authorisation/session is required and "context" gets lost?
It's like the UUIDs are no longer valid :

If I now list all albums I don't see my target album listed with the UUID as above:
... 749 HomeVids <==This is my intended target - no UUID!
... 200 HomeVids {Azase ...... OPJ73sn} <== this is the second album currently populating - with the UUID I targeted, but as text in the actual name as displayed in Google Photos.

Hope this is clear.

Hmm, somehow a duplicate "Home Vids" album got created and as soon as that happened it got the IDs suffixed onto it and you get the behaviour you saw.

I guess the thing to work out would be why the duplicate "Home Vids" got created in the first place. I suspect it might have something to do with --transfers - if you set it to 1 do you get any duplicates? If not then rclone needs a bit more internal locking.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.