Google Photos error 403, access_denied: Log in and authorize rclone for access

What is the problem you are having with rclone?

I am trying to log in and authorize rclone for access to my google photos account using "client_id" and "client_secret" from the OAuth credentials I created in When I click on the link generated by rclone config wizard, I get the following error:

   Authorization Error
   Error 403: access_denied
   The developer hasn’t given you access to this app. It’s currently being tested and it hasn’t been verified by Google. If you think you should have access, contact the developer

What is your rclone version (output from rclone version)

rclone v1.52.0

  • os/arch: linux/arm
  • go version: go1.14.3

Which OS you are using and how many bits (eg Windows 7, 64 bit)

DSM, Synology DiskStation

Which cloud storage system are you using? (eg Google Drive)

Google Photos

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

I've not come across this before...

Here are some things you could try:

Thanks, it worked after I tried with the following steps from your link:

  1. upload logo
  2. add emails
  3. add scopes
  4. add user - your email

Great! That was a super confusing error message from Google.

Hi, I got this working by publishing the application from test to production as mentioned in that link. I thought I'd try testing that it was working by changing the client_id and client_secret to slightly different values, but I've found that rclone works regardless of what I set them to. Does this mean something isn't working properly, or is this expected behaviour?

Having looked at my Google Drive API traffic, everything seems to be working, so is it just the case that the client_id and client_secret are only used when the access and refresh tokens need to be created?

That is my understanding, yes.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.