Google Photos doesn't availabe on rclone config

What is the problem you are having with rclone?

I'm trying to configure rclone for using Google Photos API but when I run "rclone config" it doesn't appear on the selection menu

What is your rclone version (output from rclone version)

rclone v1.45
- os/arch: linux/amd64
- go version: go1.11.6

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Debian 10 x64

Which cloud storage system are you using? (eg Google Drive)

Google Photos

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

root@termin-debmc605:~# rclone config
No remotes found - make a new one
n) New remote
s) Set configuration password
q) Quit config
n/s/q> n
name> gphotos
Type of storage to configure.
Enter a string value. Press Enter for the default ("").
Choose a number from below, or type in your own value
 1 / A stackable unification remote, which can appear to merge the contents of several remotes
   \ "union"
 2 / Alias for a existing remote
   \ "alias"
 3 / Amazon Drive
   \ "amazon cloud drive"
 4 / Amazon S3 Compliant Storage Providers (AWS, Ceph, Dreamhost, IBM COS, Minio)
   \ "s3"
 5 / Backblaze B2
   \ "b2"
 6 / Box
   \ "box"
 7 / Cache a remote
   \ "cache"
 8 / Dropbox
   \ "dropbox"
 9 / Encrypt/Decrypt a remote
   \ "crypt"
10 / FTP Connection
   \ "ftp"
11 / Google Cloud Storage (this is not Google Drive)
   \ "google cloud storage"
12 / Google Drive
   \ "drive"
13 / Hubic
   \ "hubic"
14 / JottaCloud
   \ "jottacloud"
15 / Local Disk
   \ "local"
16 / Microsoft Azure Blob Storage
   \ "azureblob"
17 / Microsoft OneDrive
   \ "onedrive"
18 / OpenDrive
   \ "opendrive"
19 / Openstack Swift (Rackspace Cloud Files, Memset Memstore, OVH)
   \ "swift"
20 / Pcloud
   \ "pcloud"
21 / SSH/SFTP Connection
   \ "sftp"
22 / Webdav
   \ "webdav"
23 / Yandex Disk
   \ "yandex"
24 / http Connection
   \ "http"

I have tried also to write "google photos" or "photos" but it is not recognized.
Do you know why is it happening and how to solve it?

You'll need a newer version of rclone.

See the latest release

I have installed it via "apt install rclone".
Do you know how can I get a newer version using it?

You shouldn't use any package managers as they are out of date. The install steps are actually in the help template as well:

Install (

I tried installing the new version using "curl | sudo bash" and that worked. Thank you.
Now I have the following error always I try to list the remote. Is it a bug or can be solved?

root@termin-debmc605:~# rclone ls gphotos_termin:
2021/03/09 16:02:40 ERROR : upload: error listing: directory not found
       -1 media/by-year/2002/IMG-20131005-WA0005.jpg
       -1 media/by-year/2002/IMG_20140505_190940.jpg
       -1 media/by-year/2002/IMG_20140614_153501.jpg
       -1 media/by-year/2002/IMG_20140614_153505.jpg

This is the config I have applied:

root@termin-debmc605:~# rclone config show
type = google photos
client_id = #
client_secret = #
read_only = false
token = {"access_token":"#","token_type":"Bearer","refresh_token":"#","expiry":"2021-03-09T17:00:28.91427292+01:00"}

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.