Google Drive with Plex and local read-only cache

I'm installing a new server on Ubuntu, I would like to use rclone on plex and also share on my internal network to use on another device, which way should I follow?

ok. if you want install plex on the ubuntu server, then do that

you can copy the config file from windows machine to linux machine.

I'm going to do this, I can mount the unit and then share the webdav or http tbm samba files don't seem to work with rclone, correct?

i have shared a rclone mount over samba, i have a post about that somewhere.
let me try to find it for you.

1 Like

here it is,
*Solved* Is it possible to access my Rclone mount as a Samba share?

1 Like

very good, thank you friend.

I managed to mount the unit on ubuntu, start as a service but I can't create the cache folder. I will post my service and my mistake.

Description=RClone Service

ExecStart=/usr/bin/rclone mount drive-tiago: /home/tiago/Documents/drive \
--allow-other \
--dir-cache-time 1000h \
--log-level INFO \
--log-file /home/tiago/Documents/rclone/rclone.log \
--poll-interval 15s \
--umask 002 \
--user-agent titiuser \
--rc \
--rc-addr :5572 \
--rc-no-auth \
--cache-dir=/cache \
--vfs-cache-mode full \
--vfs-cache-max-size 500G \
--vfs-cache-max-age 336h \
--bwlimit-file 16M
ExecStop=/bin/fusermount -uz /home/tiago/Documets/drive
ExecStartPost=/usr/bin/rclone rc vfs/refresh recursive=true --rc-addr _async=true



2020/12/09 15:48:23 Failed to start remote control: start server failed: listen tcp :5572: bind: address already in use
2020/12/09 15:49:12 NOTICE: Serving remote control on http://[::]:5572/
2020/12/09 15:49:15 ERROR : Failed to create vfs cache - disabling: failed to make cache directory: make cache directory failed: mkdir /cache/vfs: permission denied

I couldn't mount it except in /home/tiago/Documents/drive

I don't know much about linux.

i am not a linux expert either but @Animosity022 is....

1 Like


I still need to see how to do the samba on this my /drive. LOL


I changed the owner of the cache folder and it worked.

sudo chown -R tiago:tiago /cache
now I'm going to try the samba part.

I successfully managed the server with rclone + plex + samba on the internal network my cache on the SSD.

performance is great :star_struck:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.