*Solved* Is it possible to access my Rclone mount as a Samba share?

You have --allow-other which is what I was going to suggest.

You might also need --allow-root

If you sudo -i to root can you read the files in /home/craftyclown/Skull ?

What user is the samba server running as?

Thanks Nick,

I logged in as Root and although I could see the folder Skull, I was unable to access files within it.

It's starting to feel like --allow-root might be the answer! I'll give that a try now

The samba server is running as my home user, the same as rclone

Ah, no dice I'm afraid :frowning:

I added --allow-root to my mount and did a full reboot to ensure everything was loaded properly, but I still can't access Skull as a samba share. It is completely invisible

Hmm, not sure what to suggest next. Maybe try mounting it outside your home directory? What are the permissions on /home/craftyclown ? That might need to be 755

Yep, it's a strange one isn't it. I can't for the life of me think what is preventing access.

Permissions on the home folder are 755 and permissions on the mount, now that I've added --allow-root are 777

I think you're right about moving the mount, at least to see if it makes a difference. I'll give it a go and report back

So I moved the rclone mount and chucked it in the /media/data directory as firstly that's a far more logical place to have it and secondly because that is the same location I have my backups folder, which I can share via Samba without issues....

It still doesn't work :cry:

The only obvious difference I can see is that the backup folder is owned by root and my mount is owned by my user. I'm reluctant to change my mount user and group to root as I feel like that could be opening a can of worms, but I can't think what else to do now.

Does anyone have an inspired suggestion they can throw my way? :smiley:


i have a raspberry pi4
on the pi4, i did a rclone mount gcrypt: /home/pi/rclone/mounts/gcrypt --read-only --allow-other

i am not a linux expert but when you mentioned webmin, i have not heard of it.
i installed it and configured samba using this guide.

first time i tried, on my win10, i was able to net share the samba share named gcrypt.

i use emby, not plex.
emby on pi4 was able to see the rclone mount

Thanks asdffdsa, I'm familiar with that webmin page and as mentioned I have successfully shared other folders on the same server. It is only my rclone mount that doesn't want to play ball..

I'm presuming this is a permissions related issue, but at this stage I'm not sure what else I can try :frowning:

Soooo, still not fixed but here's what I know;

  1. Samba works fine. I know this because I can set up other shares in different directories and they work fine. I can even set up a directory with the same name as the rclone mount in the same place it used to live (inside my home folder) and that now works, since it is no longer the mount.

  2. I did wonder if the problem related to the fact it was being accessed by Plex (a long shot I know!) but I stopped the Plex Server and the problem remains.

  3. It can't be group/owner related. I know this because I have other directories with the same group/owner that are successfully working.

I really haven't a clue what is wrong

It might be worth a look in the kernel log. There might be an apparmor profile preventing it or something like that.

i know this is real basic advice.
sometimes it is good to start over.

the first time i tried webmin and samba, it did not work.
wasted a few hours and no go.
so i started with a fresh samba config file, that webmin guide and in two minutes, it was all working.

I tried running sudo apparmor_status but I couldn't see anything relevant that might be affected.

Where are you suggesting I check?

Take a look at the output of dmesg and in /var/log/kernel.log just in case there is anything interesting in there.

I presume you haven't got any containers in the mix otherwise you would have mentioned them I'm sure.

Just a thought - did you edit /etc/fuse.conf to include user_allow_other ?

Hi Nick, I do indeed have user_allow_other in my fuse.conf. I recall I needed to add it to get my mount to work. Are you suggesting it could be problematic? Or were you just checking I have it? Presuming the later :wink:

So I think I'm close to cracking the case and I'm almost certain this is a permissions issue, but sadly I lack the knowledge to dig much further :frowning:

So here's why I think its permissions based;

Firstly we know the mount works fine on it's own and has been functioning effectively for a long time, we can also say the same thing about Samba as I have multiple shares already working and I can add others without issue. I can even add a share with the same name as the mount, in the old location of the mount and that works fine, so it clearly something specific to the mount that samba is not happy about.
Secondly if I use external tools such as webmin's samba module I can quickly see anomalies such as the fact that within the directory where I have all my other working samba shares, the module shows every directory, except for the mount. If I use an sftp client I can see all of the directories, including the mount, but if I check ownership all of them bar the mount belong to root, the mount belongs to my main user.

So through a process of elimination I know that Samba is unable to detect folders owned by my user, I just don't know what I can do about it.

You need user_allow_other so that is fine.

I'm starting to think this is a samba config issue...

What happens if you take the backups config and just change the path in that to point to your mount?

Sorry Nick, I was updating my previous post when you sent yours. I'm almost certain this is an ownership issue, but I'm not sure how to fix it

The symptoms fit --allow-other missing (or not working).

When you mount a fuse FS as one user and try to look in it as another user it just appears empty I think.

However this may be a red herring here.

Eg https://superuser.com/questions/262778/set-proper-rights-for-sshfs-mountpoint-so-it-can-be-shared-with-samba

Ha ha ha, cracked it!

I just found a post from 12 days ago where you mentioned that in a recent beta --allow-other was partly broken, so I updated and et voila!

I was starting to think I was going crazy :smiley:

Ha, I should have thought of that! Glad it is fixed!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.