Google Drive: unable to upload, 403 userRateLimit

Unable to upload any file using rclone mount with Google Drive (configured with secrets). It started a week ago, even today I only uploaded 1 file of about 1gb this morning and nothing more and now it doens't work. I noticed that it stops working after about 3pm and starts working again at about 9 am of the following day.

As you can see, this morning at around 6.30 am I tried an upload but I got errors on the Create API. It Worked around 10 am and now it doesn't work anymore. Don't look at the periodic requests, it's a test I did yesterday but the previous day they weren't present and the problem was the same.

rclone version

rclone v1.65.0

  • os/version: debian 11.7 (64 bit)
  • os/kernel: 5.15.116-1-pve (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.4
  • go/linking: static
  • go/tags: none

Are you on the latest version of rclone? You can validate by checking the version listed here: Rclone downloads
--> yes

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount --vfs-cache-mode full gdrive1: /mnt/gdr --user-agent="ThisIsATest" -v

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = drive
client_id = XXX
client_secret = XXX
scope = drive
token = XXX
team_drive = XXX
root_folder_id = 

type = crypt
remote = gdrive1:/
password = XXX
password2 = XXX
### Double check the config for sensitive info before posting publicly

A log from the command that you were trying to run with the -vv flag

welcome to the forum,

not sure what the exact issue, but have you uploaded a large amount of data to gdrive in the last 24 hours?

i would try to reduce the value of --tpslimit, maybe try --tpslimit=3

and would be simpler to test+debug using rclone copy, not rclone mount

ok tried, nothing to do :frowning:

I only uploaded about 1 GB of data this morning.

I tried from another PC with another IP and different OS (Windows) too, where I created a new configuration with a new client id and client secret but the error remains.

Changing TPS limits has nothing to do with it.

If you can't upload, you are out of storage or upload quota. Nothing to do other than get more or if the out of quota, wait 24 hours and try again.

yep but I don't understand how I am out of quota/storage if I only uploaded 1 GB today. I'll wait tomorrow, it will be the same as today (locked out 'til 9 am then it will work 'til 3 pm :frowning: )

This is a Google issue.
I had this about 2 months ago, and had it again starting last week. I opened multiple tickets with Google, but no resolution. My API quota has been increased, and the volume is coming no where near the limit. I seem to get it when I copy many small files, rather than large. Like you, I have to wait a day to restart my upload. There is no console screen that shows me an error.

Unfortunately, the issue is with Google Workspace, but the only monitoring screens are on the GCP side. And GCP tech support points the finger at GWS and vice versa. Extremely frustrating.

Sorry I can't be of more help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.