Google Drive : "Shared with me" to "Shared Drive"

Hello there,

I am new to using rclone and found that it is an amazing tool.

recently I have tried basic operations like copy sync etc...

Now I want to copy the folder within google drive remote as mentioned below.

Source of the folder - Google Drive's "Shared with me"
Destination of the folder - Shared Drive's folder.

what should be my command line ?

Happy to hear that you are enjoying the tool :blush:

The initial step will be create a new remote in the config where the new remote will be your Shared Drive (remote2). This is possible to configure when you are setting up a Google Drive remote.

More details: Google drive (rclone.org)

You can access the shared with me section using the below parameter in the command:

--drive-shared-with-me

More details: Google drive (rclone.org)

So the entire command would be:
rclone copy remote: --drive-shared-with-me remote2:

Tried it, but didn't succeed.

Can you please elaborate a little more sir...

@yolobnb

@kelvinviroja93 Try to reproduce the error you get, but this time post the command(s) you used and also the log produced.

Log production: https://rclone.org/docs/#log-level-level 2.7k

hi,

when you first posted, there was a template of questions; please answer all the questions
that way we can offer better advice without having to pull everything, post by post.

the latest stable rclone is v1.61.1. are you using that?

please post the full debug output from rclone: can do that two ways.
--- add -vv to your command
--- use a log file, to your command, add --log-level=DEBUG --log-file=/path/to/rclone.log
need to change the file path to match your system.

I am using the latest stable release of Rclone.

I have successfully linked two remotes 1) for Shared Drive 2) for Main Drive

Now, what should be my command to copy file abc.exe from the "Main driver's shared with me" to "Shared Drive".

Something like

rclone copy main,shared_with_me:path/to/abc.exe shared:path/to/dir/you/want/the/file/

Note that adding the shared_with_me parameter into the connection string applies it just to the main: remote and not the shared: remote unlike using the --drive-shared-with-me flags.