Google drive shared with me folder

What is the problem you are having with rclone?

(First post so please excuse the noob, I tried to read all the directions)

I am having trouble creating a remote with a root location in the Google drive "shared with me" location. I tried using the --drive-shared-with-me flag when running rclone config, but the remote goes to the My Drive folder instead of the shared with me location. Please advise.

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config --drive-shared-with-me

I think my question is really when and how do I pass the --drive-shared-with-me flag correctly in order to create a remote that always sees the shared-with-me part of a google drive (as root).

Thanks in advance.

run rclone config and configure google drive - when asked if Edit advanced config? answer yes and it will be one of the options there


if google drive is already configured edit config and add shared_with_me = true


without shared_with_me option in config you can run any rclone command with --drive-shared-with-me flag e.g.:

rclone ls drive: --drive-shared-with-me

1 Like

Thanks @kapitainsky . As usual, a few hours after posting I figured out it may be in the advanced config.

Can you explain exactly how to pass the flag when editing? I am not confident I fully understand how to do this.

Thanks in advance.

1 Like

open rclone.config in any text editor and add the flag:

type = drive
scope = drive
token = {"access_token"XXXXX">
root_folder_id = XXXXX
shared-with-me = true <<<------- add this line ---------------

shared-with-me = true
should be
shared_with_me = true

1 Like

Thank you for spotting it

Thank you all. Super helpful.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.