Google Drive rclone client quota need bumped?

What is the problem you are having with rclone?

The Google Drive Docs Page denotes:

There is a global rate limit on the number of queries per second that each client_id can do set by Google. rclone already has a high quota and I will continue to make sure it is high enough by contacting Google.

Monitoring my rclone google drive sessions, I am seeing lots of rateLimitExceeded.

Is somebody monitoring rclone's google api usage quota and requesting increases when necessary? :slight_smile:

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0-DEV
- os/version: centos 7.9.2009 (64 bit)
- os/kernel: 3.10.0-1160.49.1.el7.x86_64 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.16.9
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -P delete drive:

The rclone config contents with secrets removed.

type = drive
scope = drive
token = ...
root_folder_id = root

A log from the command with the -vv flag

2022-02-25 14:40:46 DEBUG : pacer: low level retry 2/10 (error googleapi: Error 403: Rate Limit Exceeded, rateLimitExceeded)
2022-02-25 14:40:46 DEBUG : pacer: Rate limited, increasing sleep to 16.373707185s
2022-02-25 14:40:48 DEBUG : pacer: low level retry 2/10 (error googleapi: Error 403: Rate Limit Exceeded, rateLimitExceeded)
2022-02-25 14:40:48 DEBUG : pacer: Rate limited, increasing sleep to 16.001059868s

Thank you!

hello and welcome to the forum,

any reason for not creating your own client id?

My understanding is that the default limit with my own client is 10 req/s and I'd easily be above that and that getting increased quota from Google is tough for new clients?

Additionally, I am just verifying what the documentation says about monitoring the default client API usage.

based on forum posts, from experiened rcloners using gdrive.

--drive-pacer-min-sleep 10ms
--drive-pacer-burst 200

Thanks, but did not seem to help any, still hitting rateLimitExceeded a number of times each minute

best to answer all the questions in the help and support template.
that remote is not using your own client id,
hard to know what is going on without a full debug log.

and not sure it matters,
v1.57.0-DEV is some custom compiled third-party development version of rclone?

the only way to get the official stable client is

and no worries, here comes @Animosity022.....

1 Like

Rclone already has a pretty big quota and lots of users. There's not much Google will do to increase it.

You really should use your own client ID and secret as that fixes the issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.