Google drive mount shows empty after I accidentally added another drive account

I'm using version 1.47 and I accidentally edited my gdrive to use another non gsuite account
when i refreshed the token which promptly maxed out. I deleted the contents of that drive and edited my conf to use the correct account and refreshed the token. After restarting the mount shows nothing, but when I run rclone ls gdrive:/mnt/storage/gcloud there is a ton of encrypted files so it looks like something is there. I originally set up using Animosity022's guide with mergefs.

I found an older post, that suggested running dedupe, but running rclone dedupe gdrive:/mnt/storage/gcloud doesn't look like it does anything. Any ideas on how to fix my mistake?

What's your rclone.conf look like now?

If you changed mounts, you should be able to just remount it and the new drive should be there.

If you run something like rclone lsd gdrive: do you see the right contents?

Thanks for helping. All of this started because I was trying to figure out why my speed was capped at 2.7Mbytes I tried to remount, but it's still blank. I deleted all my mounts and started over, but it's still showing blank.

When i run rclone lsd gdrive: i get root@server:~# rclone lsd gdrive: -1 2019-05-20 10:41:12 -1 mnt

My rclone.conf looks like this

type = drive
client_id =
client_secret = xxx
scope = drive
token = {"access_token":"xxx

type = crypt
remote = gdrive:/mnt/storage/gcloud
filename_encryption = standard
directory_name_encryption = true
password = xxx
password2 = xxx

my systemd was set up under root, but i mapped to my user with the following:

Description=RClone Service

ExecStart=/usr/bin/rclone mount
ExecStop=/bin/fusermount -uz /mnt/storage/gcloud


When you check the web interface, are you seeing any files in there?

I can see the same folder path on the web portal
mnt > storage > gcloud > everything is encrypted from here.

Something weird is going on with my permissions in my mount, not sure if I messed something up when added the systemd to mount and merge as root

drwxrwxr-x 1 jeff jeff 0 May 24 12:58 .
drwxr-xr-x 11 root root 4096 May 20 09:28 ..
drwxrwxr-x 3 jeff jeff 4096 May 22 23:29 movies
drwxrwxr-x 1 jeff jeff 0 May 24 16:24 tv

On a side note, I noticed when running systemd on root it was using home from my specified user so I copied the rclone.conf to my user home and mounted.

I tried running the upload script and now I can see the new items that are being added, but still not the 600GB or so I already added.

Couple things I'd check out as there seems to a point of confusion as to what's pointing to what.

rclone config file - this shows the location of the rclone.conf

If you are using a user, I'd take the time and remove root's version if you have one so it errors out and won't start.

You have your systemd ok as you have a user / group there so it'll pick up the user's rclone.conf

If you check a rclone lsd on your remote, the part that confuses me is that you have gcrypt:crypt.

If you share your rclone.conf, that usually points to something else. Like my remote is called GD so my crypt is:

type = crypt
remote = GD:media

and I mount gcrypt: as it should be just the remote name.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.